2

I am getting 401 unauthorized exception while downloading(Excel/CSV) Powershell Reports. I have tried by adding /-/script/handle in IgnoreUrlPrefixes setting but no luck.

Sitecore Version: Sitercore 9.1

Please help me out.

Thanks, Joy

enter image description here

3 Answers 3

7

We had the same issue and solution was to enable Spe.IdentityServer.config at \inetpub\wwwroot\website\App_Config\Include\Spe.

OOTB this file comes with Sitecore Powershell module as disabled. Just need to remove .disabled from the config name.

enter image description here

1

I encountered a similar problem in Sitecore version 10.3, and I found a solution. To resolve this issue, please add the provided line of configuration to the siteNeutralPaths node in the specified path.

In the path D:\inetpub\wwwroot\<instance name>\App_Config\Sitecore\Owin.Authentication\Sitecore.Owin.Authentication.config, add the line:

<path hint="spe">/sitecore%20modules/PowerShell</path>

.enter image description here

0

This issue occurs in Sitecore 9.1+ instances.


Solution:- Add below mentioned line to allow powershell to download/upload files like export excel/csv etc.

File Name:- C:\inetpub\wwwroot\\App_Config\Sitecore\Owin.Authentication\Sitecore.Owin.Authentication.config

Please confirm what needs to be added to the Sitecore.Owin.Authentication.config for this issue

2
  • I've already uploaded image and shared link for the solution. Please check i.stack.imgur.com/dhtNT.jpg Oct 2, 2019 at 17:21
  • There is actually a configuration file included with SPE 5.1+ which patches the appropriate setting for Identity Server support. Oct 2, 2019 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.