9


I know that there are lot of question have been asked on this topic but my concern is that after following all the available options Forms are still not appearing on Form interface.
However I can see form under content tree.

enter image description here enter image description here

Other Details:- I am using Sitecore.NET 9.0.2 (rev. 180604) and also using Sitecore Forms Extensions for Sitecore 9.0-1.8.2

I have performed the following the steps:-

  • Rebuilding master indexes
  • Renaming Sitecore forms
  • Check the Form folder id in core database, ID matches
  • Clear browser cookies
  • define "is_template" field from "istemplate" field

I have taken the references from the following URLs and Sitecore StackExchange questions: -

No forms are displaying in Sitecore 9 Forms area

https://doc.sitecore.com/developers/90/platform-administration-and-architecture/en/the-search-and-indexing-configuration-files.html

https://citizensitecore.com/2017/11/19/sitecore-9-forms-form-doesnt-show-up-after-creation/

Why I can't see my forms/templates in the Sitecore Forms application?

https://sitecoresandbox.com/2018/03/09/there-are-no-forms-to-display-in-sitecore-9-forms-designer/

I am not sure what I have missed. Any help would be much appreciated.

Thanks in advance.

  • 1
    Have you seen this KB article with patch from Sitecore? Looks like it was added today (May 29th): kb.sitecore.net/en/Articles/2019/04/30/08/28/891856.aspx – Richard Seal May 29 at 16:11
  • @RichardSeal I checked this KB article and tried first solution but it did not workout. Rest of 2 fixes are included in Sitecore 9.0.2 version so did not tried them. Still the same situation. – SumitK May 31 at 11:41
  • What search provider? Also try use a different browser, sometimes Chrome isn't working consistently recently with Sitecore. Otherwise, open a support ticket and report back when they figure it out. – Mark Gibbons Jun 9 at 6:27
  • @MarkGibbons We are using SOLR as search provider. I have tried different browsers and Incognito window, private window as well. Now the issue has been resolved. I'll be posting the solution here. – SumitK Jun 14 at 7:44
  • 1
    I had to add the config patch and rebuild master indexes and all was well again for me :) kb.sitecore.net/en/Articles/2019/04/30/08/28/891856.aspx – Dave Goosem Aug 9 at 5:21
4

As mentioned above I have followed various solution referring various links but nothing worked for me. After deep diving into the issue we found that there are few changes in the configuration files for SOLR and Lucene which created the fuss for me.

After replacing all necessary files (specifically related to indexes) from the same replica of instance (vanilla installation) and rebuilding the indexes, my issue got resolved.

But for future references I am mentioning all the solution which I have followed:-

Solution 1: Rebuilding master indexes
Initially rebuilding master indexes did not resolve the issue but as mentioned above after replacing few configuration files from fresh instance and then rebuilding the master indexes resolved the issue.

  • This worked for me.

Solution 2: Renaming Sitecore forms
Sometime renaming the form will do the trick and resolved this issue. I had faced this situation in my previous project and renaming the form had solved this issue for me. But this time did not work.

Solution 3: Check the Form folder id in core database
Check the ID of Form folder in Root field of SearchConfig item in core database at /sitecore/client/Applications/FormsBuilder/Components/Navigation/Create/PageSettings/CreateFormDataSource/SearchConfig SearchConfig item id - {60F35FD9-88CB-4DF5-8E78-1E9BF5FE181C} If found different change it to the folder id where forms are present.
Form folder Id was same in my case.

Solution 4: Clear browser cookies
I have found on the sitecore.stachexchange.com that clearing browser cookie had resolved the same issue for one community user. So tried the same thing and even in new browser as well.

Solution 5: define "is_template" field from "istemplate" field
I have found error in Search logs as given below: - enter image description here

13020 13:55:57 ERROR Solr Error : ["undefined field is_template"] - Query attempted: [(((((_content:(**) OR _name:(**) OR _displayname:(**)) AND (is_template:(0) AND _latestversion:(1))) AND _path:(b701850acb8a4943b2bcdddb1238c103)) AND _templatename:(Form)) AND (-__hidden:(1)  *:*))]
17204 13:55:57 ERROR Solr Error : ["undefined field is_template"] - Query attempted: [(((((_content:(**) OR _name:(**) OR _displayname:(**)) AND (is_template:(1) AND _latestversion:(1))) AND _path:(b701850acb8a4943b2bcdddb1238c103)) AND _templatename:(Form)) AND (-__hidden:(1)  *:*))]

Taken the reference as mentioned in the question, I made changes accordingly. Error was saying that "undefined field is_template" so I added the field with the same name as shown below in Sitecore.ContentSearch.Solr.DefaultIndexConfiguration file at C:\inetpub\wwwroot\your sitecore instance\App_Config\Sitecore\ContentSearch

enter image description here enter image description here

And rebuild the indexes again. Rebuild indexes completed successfully.
Error from SOLR gone but forms were not visible by this solution as well.

  • Is this a solution if it's still not showing you Forms? – Peter Procházka Jun 18 at 6:25
  • @PeterProcházka Solution no.1 is the solution in my case. I have just mentioned all the steps which I have followed as to benefited others in case. As solution no.2 worked for me in my previous project. So just thought may be it will help others in future. – SumitK Jun 18 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.