0

Our Sitecore's solr search engine is a master-slave setup. One of the cores of the Slave is corrupted and is not available at all in Slave.

It is not being replicated from Master too (Expecting index replication to do this but core is completely missing in Slave). As read in index replication documentation, all the queries are handled by Slave part of the set up.

What happens to the queries that are handled by this core that is missing in slave?

Will they be taken over by Master?

Please help me as I can find no info about this anywhere else. For info the core that is missing is of Sitecore analytics index.

0
  1. If the necessary core is not present on the slave it will not be queryable by Sitecore.
  2. The Solr Master will not "take over" as it is not exposed to, or queryable by the Content Delivery (CD) servers.

Let me explain why...

In a typical setup the master is unaware of the slaves. The slaves will poll the master at a preset poll interval (eg. 60 seconds). If the index on master is a newer version, the new files making up the changes are downloaded to the slave and the slave reloads the updated index.

The CD servers query only the slave indexes (often via a load balancer). These servers should be set up to use a manual index strategy so that they never update the slaves. If this is not set, the slaves will get out of sync with master and have to re-download the entire index regularly killing performance and bandwidth.

I would start by investigating why your core is missing from the slave in question in the usual fashion; Search the logs for errors, check the replication configuration, try querying the index manually through the Solr web interface as a start. Ensure the replication process it functioning correctly.

  • Missing core just hit me like a bolt from the blue. I tried checking logs only to find that core is corrupted. Do you know any reasons why this happens? I couldn't find any reason and after an extensive search in google, came to a conclusion that a core can be corrupted because of many reasons like sudden shut down or restart of server while indexes are updating etc., please let me know if you have any info on this too! – YENUGUDHATI MAHESH VARMA May 29 at 14:32
  • Coming to "try querying the index manually". Sorry I am a bit layman here. I tried doing it in master by selecting query under the specific core in core selector available in solr dashboard (web interface). But in slave the whole core is missing so I couldn't do this. Is this correct way of doing it? Can you please let me know the correct way of doing it if this is not! – YENUGUDHATI MAHESH VARMA May 29 at 14:35
  • @YENUGUDHATIMAHESHVARMA Investigation into the issue itself doesn't really fit within the scope of your original question. If you are happy with the answer, I suggest further discussing your problems either in a chat, in the #solr channel in Sitecore Slack or by raising a new question demonstrating your findings so far. – sitecorium May 29 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.