2

I get the following error from my CD Server(serverB)

The certificate was not found. Store: My, Location: LocalMachine, FindType: FindByThumbprint, FindValue: """"", InvalidAllowed: False.

Source: Sitecore.Xdb.Common.Web

My distributed setup is as follows

I have a 2 server setup

ServerA - CM with reporting (installed using XP0 and NOT XP1 script)

ServerB - copied the CD website from serverA and imported the XConnect client certificate from server1

I have the original CD website on server1 which came with the XP0 setup which is working fine. The error is only on the CD website on server2

One more thing the XConnect from serverB to serverA is through an invalid https(read XConnect server certificate) connection!

1

Please check the below things.

1- Check the connection string on ServerB and check "xconnect.collection.certificate" has the same thumbprint that you have for Xconnect certificate on ServerA.

2- Make sure your server certificate (SSL) for XConnect is valid and can be validated from ServerB.

3- run MMC and check that certificate is exist in your local machine

4- And In MMC>localmachine> edit the permission for certificate and give full control to account(Network Service/something else) in which application is running.

Let me know if you are facing any issue for the above points

Thanks

0

Can you try this way:

Server-B:

  • import the XConnect Cert into "Cert:\LocalMachine\Root" --> in order to make a request to XConnect
  • import the XConnect Client Cert into "Cert:\LocalMachine\My" --> in order to pass the security check of XConnect

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.