0

I deploy with this command:

jss deploy app --includeContent --includeDictionary

When I do I get the following error:

Exception thrown while importing JSS app
Exception: System.InvalidOperationException
Message: args.App.ImportUser is null or empty
Source: Sitecore.JavaScriptServices.AppServices
   at Sitecore.JavaScriptServices.AppServices.Pipelines.Import.SwitchUser.Process(ImportPipelineArgs args)
   at (Object , Object )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists)
   at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain)
   at Sitecore.JavaScriptServices.AppServices.Pipelines.Import.ImportPipeline.Import(ImportPipelineArgs args)
   at Sitecore.JavaScriptServices.AppServices.ImportService.ImportJob.StartImportInternal()

How do I fix this?

0

When you do the Sitecore JSS Server Setup, There is a step: Install the JSS Server Components zip package using the Installation Wizard.

This package also create an User in Sitecore, and Install some config files.

In file:

\App_Config\Sitecore\JavaScriptServices\Sitecore.JavaScriptServices.Apps.config

Is the ImportUser defined: The default value is:

importUser="sitecore\JssImport"

So check that this config file exists in the Sitecore webroot and that the ImportUser is filled in.

Also check the config with /sitecore/admin/showconfig.aspx possible the ImportUser is overwritten by another config file:

An option to fix this could be re-install the Package. Sitecore JavaScript Services Server for Sitecore

Check your deployUrl in the {appnam}config.json: This should be CM Sitecore sever.

  • /sitecore/admin/showconfig.aspx shows the importuser, I've also "enabled" the import user from sitecore. The deploy url in scjssconfig.json seems correct. Also I get the message : Sitecore has accepted import task JSSImport-jss-6:04:25 PM – devzero May 31 at 16:07
0

So this error was because I'd changed : "app name=" in the [appname].config file. To change this you need to change 4 places.

[appname].config => <app name="
[appname].deploysecret.config = <app name="
package.json => "config": { "appName": 
package.json => "sitecoreDistPath": "/dist/

I would also recommend manually delete all config files from the app_config/include/zzz folder and removing as many traces as possible from the templates/renderings and content for the old app. Also delete the /dist folder files from the IIS folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.