1

One specific content item is not rendering, showing blank page.

When we check log found below exception:

Exception: System.InvalidOperationException Message: The Sitecore.Client.ContentDatabase is null. Source: Sitecore.Kernel at Sitecore.Client.get_ContentDatabase() at Sitecore.Layouts.RenderingReference.ParseRules(XmlNode configNode, RenderingItem renderingItem) at Sitecore.Layouts.RenderingReference.ParseSettings(XmlNode configNode) at Sitecore.Mvc.Analytics.Pipelines.Response.CustomizeRendering.CustomizeRenderingProcessor.GetRenderingReference(Rendering rendering, Language language, Database database) at Sitecore.Mvc.Analytics.Pipelines.Response.CustomizeRendering.Personalize.Evaluate(CustomizeRenderingArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs,TResult](String pipelineName, TArgs args, Func `2 resultGetter) at Sitecore.Mvc.Analytics.Pipelines.Response.GetRenderer.CustomizeRendering.Process(GetRendererArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs,TResult](String pipelineName, TArgs args, Func`2 resultGetter) at Sitecore.Mvc.Presentation.Rendering.GetRenderer() at Sitecore.Mvc.Presentation.Rendering.get_Renderer() at Sitecore.Mvc.Presentation.Rendering.ToString() at Sitecore.Mvc.Pipelines.Response.RenderRendering.InitializeProfiling.StartProfiling(RenderRenderingArgs args) at Sitecore.Mvc.Pipelines.Response.RenderRendering.InitializeProfiling.Process(RenderRenderingArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args) at Sitecore.Mvc.Pipelines.Response.RenderPlaceholder.PerformRendering.Render(String placeholderName, TextWriter writer, RenderPlaceholderArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args) at Sitecore.Mvc.Helpers.SitecoreHelper.Placeholder(String placeholderName)

Any suggestion to figure out this issue.

  • There seems to be something wrong with one of your renderings (or a rule on a rendering). Try removing them one by one to figure out which one.. – Gatogordo Jun 4 at 9:10
5

ParseRules method uses this code to pass proper database to RuleFactory:

renderingItem != null ? renderingItem.Database : Client.ContentDatabase

If it tries to pass Client.ContentDatabase (that's in your exception stack trace) it means that renderingItem is null.

So it looks like either one of the renderings which was added to presentation details of that page no longer exists or maybe it was not published to web database yet.

Check the presentation details of the page in master database first. See which of the renderings has some rules assigned. Then switch to web database. Check if that rendering is also in the web database.

If none of the components has rules assigned, check all the renderings if all of their definitions are present in web database.

0

Just for explaining exact fix. This issue was due to newly added renderings were not published to web DB.

Once publish required renderings, content item started showing proper content.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.