3

I am using SXA 1.8 with my Sitecore 9.1 instance.

I have a tenant and 2 sites Site A and Site B underneath it. For Site A, I have configured the sitemap settings in Search Engine Sitemap section using Sitemap Mode "Store in File".

After saving and publishing, I see that my sitemap gets generated. However, I am unable to find the physical location of this.

Does anyone have any idea about this?

0

It's generated in TempFolder.

By default it's just "/temp" folder inside your web application.

But this can be overriden with TempFolder setting, e.g.:

<setting name="TempFolder" value="/some-other-temp-folder"/>

Sitemap file name is sitemap-NAME_OF_THE_SITE.xml

As far as I know, SXA robots.txt content is never stored in a file.

  • It looks like in 1.8.1, there may be a bug with this. My sitemaps are all created as sitemap-website.xml, and whichever sites sitemap is called first after a publish, that is the one that all sites are getting. – Richard Seal Jun 5 '19 at 11:35
  • Interesting. Have you raised Support ticket? Or pinged Adam? ;) – Marek Musielak Jun 5 '19 at 11:37
  • 1
    In the process :) – Richard Seal Jun 5 '19 at 11:37
  • @MarekMusielak, yes I found it. It gets generated in the "/temp" folder. The file name is "sitemap-shell.xml". But shouldn't the name be site-specific?? Also, should I be getting two sitemap files for each site?? – Ruchi Yevle Jun 5 '19 at 12:17
  • 2
    Yeah - I confirmed with the SXA team, its a known bug. I would stick to Stored in cache – Richard Seal Jun 5 '19 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.