3

A client is using another form solution, so we do not want to use Sitecore Forms. Previously, we would have just not installed WFFM on their solution, but in Sitecore 9, Sitecore Forms is built-in.

Is there a way to disable it entirely?

  • Is Sitecore form conflicting with your custom form solution? I also have custom form solution in my project, we didn't touch sitecore forms and left as is. Only thing is you can remove sitecore form node in content tree to avoid any confusions to content author. – S.Kazmi Jun 6 '19 at 23:55
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question. - From Review – Dylan Young Jun 7 '19 at 4:38
  • Sometimes answer lies in the question. – S.Kazmi Jun 7 '19 at 5:35
1

Non admin users without the sitecore\Forms Editor role should not see the Forms Editor button and do not have write access to sitecore/forms tree

It is about this rights.

Item Rights set on sitecore\Forms Editor on core Database
/sitecore/client/Applications/FormsBuilder  Read right for items.   item:read   AllowAccess,    Entity
/sitecore/client/Applications/FormsBuilder  Read right for items.   item:read   AllowAccess,    Descendants
/sitecore/client/Applications/Launchpad/PageSettings/Buttons/Marketing/Forms    Read right for items.   item:read   AllowAccess, Entity

Item Rights set on sitecore\Forms Editor on master Database
/sitecore/Forms Read right for items.   item:read   AllowAccess, Entity
/sitecore/Forms Create right for items. item:create AllowAccess, Entity
/sitecore/Forms Rename right for items. item:rename AllowAccess, Descendants
/sitecore/Forms Create right for items. item:create AllowAccess, Descendants
/sitecore/Forms Delete right for items. item:delete AllowAccess, Descendants
/sitecore/Forms Read right for items.   item:read   AllowAccess, Descendants
/sitecore/Forms Write right for items.  item:write  AllowAccess, Descendants

You can solve this with the correct rights, don't give sitecore\Forms Editor right, and if this is a issue for Admin users, the should know what they do. Than you can adjust this rights.

0

Looks like Forms does not have a setting like EXM : <add key="exmEnabled:define" value="yes"/>

The easiest way to not show Forms database is to delete the item: /sitecore/client/Applications/Launchpad/PageSettings/Buttons/Marketing/Forms from the core Database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.