0

I have a Sitecore 9.1 XP local dev installation with self-signed certificates.

This is how the SSL Certificate for my Collection instance is configured:

<add name="xconnect.collection" connectionString="https://XPScaled910.collection" />
<add name="xconnect.collection.certificate" connectionString="StoreName=My;StoreLocation=LocalMachine;FindType=FindByThumbprint;FindValue=621B26950DC9DE426493B9698ECA36CDBD4CD26A" />

The XPScaled910.collection certificate is correctly configured in the PERSONAL store of the Local Computer, and the Application Pool identity of the Sitecore XP server has access to it (I edited the permissions):

enter image description here

When I run the xConnect Client Endpoint troubleshooter I get a Could not create SSL/TSL secure channel error and the following entry in the Windows Event Viewer:

enter image description here

But this does not tell me much about what steps to undertake next in order to resolve the error.

QUESTION

What does this Window Event ("Audit Failure") tells me? How can I overcome the

1

Can you please try below two fixes.

  1. Check client certificate Thumbprint value in config file is maching with the certificate Thumbprint.

  2. Give certificate access to app pool user.

  • Hi S.kazmi - the Thumbprint specified in the certificate thumbprint belongs to a certificate called "XPScaled910.xconnect_client". Is that correct? Where should this certificate be employed? – Emanuele Ciriachi Jun 11 at 9:27
  • Thanks! This did the trick. The issue was that the Sitecore XP Server had no access to the XPScaled910.xconnect_client, which is the one associated to the "xconnect.collection.certificate" via thumbprint. – Emanuele Ciriachi Jun 11 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.