I'm using Sitecore 9.1 and SXA 1.8, the autosuggest works after entering two characters if I want to change it and make it work like after three characters, Where can I change it.


From what I can see in component-search-box script, there is hardcoded value 2:

typeahead = this.$el.find(".search-box-input").typeahead({
    hint: true,
    minLength: 2

I don't know if there is any easy way to change it via config but worst scenario, you can edit the content of the script and use whatever value you want.

| improve this answer | |
  • I made this change since no option to configure. – Michael West Jun 19 '19 at 4:44
  • @MichaelWest That would be a good improvement. I will note this in our backlog. – Dawid Rutkowski Jun 19 '19 at 6:48
  • Thanks too much for your effort, this helped me. – Mohamed Yaseen Mosa Jun 19 '19 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.