1

EDIT: SEE MY ANSWER BELOW FOR THE FIX.

While trying to install Sitecore 9 via the install PowerShell script provided in the "Sitecore® Developer Foundation 9.0" Course, I've ran into the following error.

I have found and tried several "fixes", however none seem to work for me, any assistance would be greatly appreciated.

Edit for some of the fixes:

"Could not deploy package" error while installing Sitecore 9 update 2 setup on Remote server

https://sitecoresolver.blogspot.com/2017/11/sitecore-xp-90-local-instance-setup.html

https://born4joy.wordpress.com/2018/10/27/sitecore-9-installation-error-sql-server-data-tier-application-framework/

Error:

[---------------------------------------------- InstallWDP : WebDeploy -----------------------------------------------] [WebDeploy]:[Path] C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe                                            Info: Adding MsDeploy.Site (MsDeploy.Site).
Info: Adding database (user id=sa;data source=NE1-LTP-1596\SQLEXPRESS;initial catalog=xp0_Processing.Pools)
Info: Initializing deployment: Pending.
Info: Analyzing deployment plan: Pending.
Info: Updating database: Pending.
Info: Creating deployment plan: Pending.
Info: Verifying deployment plan: Pending.
Info: Deploying package to database: Pending.
Info: Creating deployment plan: Running.
Info: Initializing deployment: Running.
Info: Initializing deployment (Start)
Info: Initializing deployment: Faulted.
Info: Initializing deployment (Failed)
Info: Creating deployment plan: Faulted.
Info: Verifying deployment plan: Faulted.
Info: Deploying package to database: Faulted.
Error: Could not deploy package.
Error: Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
Error: Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
Error Code: ERROR_EXECUTING_METHODError count: 1.

More Information: Could not deploy package.
Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
Internal Error. The database platform service with type Microsoft.Data.Tools.Schema.Sql.Sql130DatabaseSchemaProvider is not valid. You must make sure the service is loaded, or you must provide the full type name of a valid database platform service.
  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_EXECUTING_METHOD.
Install-SitecoreConfiguration : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero
exit code - (-1)
At C:\SitecoreDev\install.ps1:42 char:1
+ Install-SitecoreConfiguration @xconnectParams
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:08
Invoke-CommandTask : Command C:\Program Files\iis\Microsoft Web Deploy V3\msdeploy.exe returned a non-zero exit code -
(-1)
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Tasks\Invoke-WebDeployTask.ps1:36
char:2
+     Invoke-CommandTask -Path $Path -Arguments $msdeployArgs -TaskName ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-CommandTask
2
1

Long story short, you didn't follow the prereqs for installing Sitecore 9.

You're deploying a SQL Server 2016 DACPAC into something I suspect is not SQL 2016 with DACPAC support.

Go back to the list of prereqs for your install and make sure no steps are omitted.

2
  • After double checking, i did actually have SQL Server 2017 Installed. I'll switch to 2016 and see if it makes a difference – Captain Squirrel Jun 19 '19 at 14:28
  • Installed SQL Server 2016, still the same error. – Captain Squirrel Jun 19 '19 at 14:58
0

As Mark Cassidy mentioned in his post, the issue was down to the wrong SQL version being installed (SQL Server 2016 is required for Sitecore 9), however I then encountered another issue.

Error: Unable to connect to master or target server 'xp0_Processing.Pools'. You must have a user with the same password in master or target server 'xp0_Processing.Pools`

This was solved by changing the Security Settings to allow for Mixed authentication, as mentioned by SiteCoreSpark on their blog - https://www.sitecorespark.com/blog/2017/11/sitecore-installation-framework-error-processing-pools

Not the answer you're looking for? Browse other questions tagged or ask your own question.