2

i've a Sitecore 9.1.1 website on a Windows server2016 with IIS 10. I've enabled the xDb features but the "Personalize" button in the rendering details section is not available.

I've seen that the button is only hidden (display: none), so I modified the style attribute in Chrome inspector, then I've clicked the button and the "Personalize the component" popup has been shown, but the rules are always disabled.

I can add/change the rules, or the personalization and everything will be saved when i confirm the operation, but if I reopen the popup the personalization rules are always disabled, neither they will be applied on the final page rendering.

  1. How can I enable the "Personalize" button without changing the style attribute?

  2. Why my personalization rules are always disabled?

  • Are you logged in as an admin or a normal user? – Chris Auer Jun 28 at 2:17
  • Do you mean this button? screencast.com/t/f7hbrAAIJjUM – Artsem Prashkovich Jun 28 at 9:08
  • @ChrisAuer yes as admin – Tharnadar Jun 28 at 9:15
  • Have you tried with a different (more up to date) license file? Just wondering if it's making a check for something and you don't have the right key. – Jason St-Cyr Jun 28 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.