2

On my instance of Sitecore 8.2 Update 7, the database selection list in the lower right hand corner show two webs:

enter image description here

There is only one web in publishing targets:

enter image description here

And my connection strings only have one web databse:

<?xml version="1.0" encoding="utf-8"?>
<connectionStrings>

<add name="core" connectionString="Data Source=myserver;Persist Security Info=False;Database=MyDatabase_Core;User Id=myuser;Password=*****" />
<add name="master" connectionString="Data Source=myserver;Persist Security Info=False;DatabaseMyDatabase_Master;User Id=myuser;Password=*****;" />
<add name="web" connectionString="Data Source=myserver;Persist Security Info=False;Database=MyDatabase_Web;User Id=myuser;Password=*****;" />

<!--(XDB -Powered by Sitecore Inc.) xDB Databases Connection Strings-->
<add name = "analytics" connectionString = "mymongo_dev_analytics_cloud1_cm"/>
<add name = "tracking.contact" connectionString = "mymongo_dev_tracking_contact_cloud1_cm"/>
<add name = "tracking.live" connectionString = "mymongo_dev_tracking_live_cloud1_cm"/>
<add name = "tracking.history" connectionString = "mymongo_dev_tracking_history_cloud1_cm"/>

<add name="reporting" connectionString="Data Source=myserver;Persist Security Info=False;Database=MyDatabase_Reporting;User Id=myuser;Password=*****;" />
<add name="session" connectionString="Data Source=myserver;Persist Security Info=False;Database=MyDatabase_Sessions;User Id=myuser;Password=*****;" />
<add name="custom" connectionString="Data Source=myserver;Persist Security Info=False;Database=MyDatabase_Custom;User Id=myuser;Password=*****;" />
<add name="custom-ef" providerName="System.Data.SqlClient" connectionString="TrustServerCertificate=False;Data Source=myserver;Database=MyDatabase_Custom;User Id=myuser;Password=*****;" />
</connectionStrings>

Is this list stored as content somewhere? How can I clean it up?

4

The databases which are shown in Database Selector on Sitecore Desktop are taken from the Sitecore configuration.

Open /sitecore/admin/showconfig.aspx and find there <databases> node directly under <sitecore> node. You will found there more than 1 databases with id attribute set to web.

<database id="core" singleInstance="true" type="Sitecore.Data.DefaultDatabase, Sitecore.Kernel" patch:source="Sitecore.Buckets.config">
   ...
</database>
<database id="master" singleInstance="true" type="Sitecore.Data.DefaultDatabase, Sitecore.Kernel" patch:source="Sitecore.Buckets.config">
   ...
</database>
<database id="web" singleInstance="true" type="Sitecore.Data.DefaultDatabase, Sitecore.Kernel" patch:source="Sitecore.Buckets.config">
   ...
</database>
<!-- second web database -->
<database id="web" singleInstance="true" type="Sitecore.Data.DefaultDatabase, Sitecore.Kernel" patch:source="Sitecore.Buckets.config">
   ...
</database>
  • Due to a badly configured patch, web was defined twice. Thanks. – Ethan Schofer Jul 2 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.