0

I setup Sitecore Publishing Service on my server correctly. It worked fine for week. But it started throwing error whenever I try to publish any item

Error : Could not resolve stores: 'public' of type target

I checked publishing service logs and found below error

2019-07-04 06:23:44.830 -07:00 [Information] Service Version   : "3.1.44"
2019-07-04 06:23:44.859 -07:00 [Information] Environment type  : "Production"
2019-07-04 06:23:44.861 -07:00 [Information] Log Level Filter  : "Default" => Warning
2019-07-04 06:23:44.861 -07:00 [Information] Log Level Filter  : "Sitecore" => Information
2019-07-04 06:23:44.861 -07:00 [Information] Listening on      : "http://localhost:40582"
2019-07-04 06:23:44.861 -07:00 [Information] Instance name     : "85ac4a37-9ce8-4bbd-bbec-5d5520218c62"
2019-07-04 06:23:45.254 -07:00 [Information] Source registered : "Master" ("Master")
2019-07-04 06:23:45.254 -07:00 [Information] Target registered : "Public" ("Public")
2019-07-04 06:23:45.323 -07:00 [Information] Scheduled Task    : "PublishTask-d2aef83be20c49cab25b13e3695a7440"
2019-07-04 06:23:45.323 -07:00 [Information] Scheduled Task    : "PublishJobCleanupTask-6cde74f286cb4ed1ad7b851af35ccbba"
2019-07-04 06:23:45.324 -07:00 [Information] Scheduled Task    : "PublishOperationCleanupTask-8ebf9e001c2b429bb42bc7ac47586c94"
2019-07-04 06:23:45.333 -07:00 [Information] Starting Instance Activation monitor ("MultiInstanceActivationStrategy") on "85ac4a37-9ce8-4bbd-bbec-5d5520218c62"
2019-07-04 06:23:45.376 -07:00 [Information] Instance Enabled  : False ("85ac4a37-9ce8-4bbd-bbec-5d5520218c62")
2019-07-04 06:23:45.402 -07:00 [Information] Scheduler Status  : Stopped

Here I can Instance enabled is false when I first installed it then it was true

2

It looks like you have a custom publishing target (public) that you are trying to publish to. First thing I would check is the casing of public. From the sparse logs you provided, it looks like there is a Public target configured but you may want to update your publishing target name in Sitecore to be Public instead of public as a first step.

You will want to make sure that the various configurations in /config/sitecore/publishing/sc.publishing.xml are updated accordingly to match exactly to what your custom publishing target is.

Settings/Sitecore/Publishing/Services/DefaultConnectionFactory/Options/Connections

Make sure you have a <public> node in this section of the XML and configured with the appropriate connection string. The name of the node needs to match the name of the publishing target in Sitecore.

Settings/Sitecore/Publishing/Services/StoreFactory/Options/Stores/Targets

There will also need to be a <public> node in this section as well with the <ConnectionName> node containing the value of the name of the node previously defined in DefaultConnectionFactory, which in this case is public.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.