0

On the shared site setup, no search results being returned when Geofiltering is applied. On the page load, results are rendered on the page. We noticed the below search query being generated when geo filtering is applied

({!geofilt pt=36.0402159,-115.2244853 sfield=geolocation_rpt d=0 score=distance filter=false} 
AND ((_template:(1b15892a20924d28bea7d509c9711d05) AND (_path:(**Consumer site ID**) AND ispoi_b:(True))) AND _latestversion:(True)))

We believe the search query should be one of the following

({!geofilt pt=32.7630226,-96.3013432 sfield=geolocation_rpt d=0 score=distance filter=false} AND 
((_template:(1b15892a20924d28bea7d509c9711d05) AND (_path:(**Shared site ID**) AND ispoi_b:(True))) AND _latestversion:(True)))

or

({!geofilt pt=32.7630226,-96.3013432 sfield=geolocation_rpt d=50 score=distance filter=true} AND 
((_template:(1b15892a20924d28bea7d509c9711d05) AND ((_path:(**Consumer site ID**) OR _path:(**Shared site ID**)) AND ispoi_b:(True))) AND _latestversion:(True)))

On the Solr UI interface, both the above queries are working for the Geo filtering.

Any thoughts or suggestions to make it work?

  • This is a preaty old version of SXA. Do you have a chance to test it on the yesterday released SXA 1.9? If no please create a support ticket. That way we will have time to test it and prepare hotfix if needed. – Dawid Rutkowski Jul 23 at 9:00
  • Yes, I do have a support ticket created for the issue. – Lan Chandrasekaran Jul 24 at 13:41
  • The above issue has been registered as a bug in SXA 1.7.0. Refer to the Public reference number: 347831. – Lan Chandrasekaran Aug 2 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.