0

I switched from Solr to Azure search and followed all the steps listed in the blog. I Also renamed the Solr core to lower case with dashes. When I run the xConnectSearchIndexer -rr service the indexes are created in the Azure but the names are different.

The master index name is sitecore-master-index-732 instead of just sitecore-master-index.

Is there some configuration/step that I have set incorrectly or missing?

5

This is normal behaviour in Sitecore 9.1+ and is not a problem. You have Sitecore Azure Search switch on rebuild enabled, so it will append a random number to the index name when rebuilding and then switch to using it once the rebuild is complete. It should then delete the old index.

  • Thanks for the clarification Mark – Renuka Jul 26 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.