4

I am trying to install the Sitecore PowerShell extensions module in Sitecore 9.2. While installing this module, I received a w3wp crash error as:

Enter image description here

When I try to run any script, I am receiving "Sitecore.Jobs.Jobs" error as:

Enter image description here

Is the Sitecore PowerShell extensions module compatible with Sitecore 9.2?

  • Which version of SPE you try to install? – Marek Musielak Jul 25 at 9:12
  • @MarekMusielak .. It was latest "Full 5.0 release". – SurendrA SharmA Jul 25 at 10:40
12

I do know that I personally built 5.1 to address the compatibility issue with jobs.

I encourage you to consider trying that to confirm it corrects the issue.

https://github.com/SitecorePowerShell/Console/releases

For some clarification. The official SPE builds on GitHub have embedded the VersionSpecific dll into the primary dll. When the installation takes place that file gets deleted because it's no longer needed on the disk. The builds hosted by Sitecore were essentially recompiled to target Sitecore 9.2 and do not contain the same exact code as seen in the official SPE builds.

  • Thank you Mike, Could you please release this release 5.1 version on the marketplace as well? people usually download it from there :) – Mahendra Shekhawat Jul 25 at 12:15
  • I have submitted it on the Marketplace this morning. Hope to see it available soon. – Michael West Jul 25 at 12:31
  • Thanks mike for your efforts. I tried with built 5.1 and while installing I again received w3wp issue but after completing the installation I am able to run the scripts successfully now. – SurendrA SharmA Jul 25 at 12:35
  • I am very happy to hear that. Please consider marking the answer that most addressed your issue. – Michael West Jul 25 at 13:04
  • Thanks, Mike! I think there is a documentation bug on Sitecore SXA 1.9.0 download page: dev.sitecore.net/Downloads/Sitecore_Experience_Accelerator/19/…. It contains a link to download SPE 5.0 for Sitecore 9.2. – Hugo Santos Jul 26 at 13:47
5

On Sitecore 9.2, the Jobs API changed. You should use either:

Regarding the w3wp crash, it looks very similar to this xConnect crash KB: https://kb.sitecore.net/articles/494291

If you are on a Windows 10 build older than 1809, could you try installing the ".NET Framework November 2018 Security and Quality Rollup" as mentioned in the KB solution?

If you are on Windows 10 1809 or newer, could you try the binding redirect workaround?

Before:

<dependentAssembly>
    <assemblyIdentity name="System.Security.Cryptography.Algorithms" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" xmlns="urn:schemas-microsoft-com:asm.v1" />
    <bindingRedirect oldVersion="0.0.0.0-4.3.0.0" newVersion="4.3.0.0" xmlns="urn:schemas-microsoft-com:asm.v1" />
</dependentAssembly>

After:

<dependentAssembly>
    <assemblyIdentity name="System.Security.Cryptography.Algorithms" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" xmlns="urn:schemas-microsoft-com:asm.v1" />
    <bindingRedirect oldVersion="0.0.0.0-4.3.0.0" newVersion="4.0.0.0" xmlns="urn:schemas-microsoft-com:asm.v1" />
</dependentAssembly>
2

No, Sitecore 9.2 released just a few days ago and it has a new Sitecore.Kernel dll, the latest Sitecore PowerShell extension module has lots of dependency on Sitecore.Kernel. With the latest release, you will not find the Sitecore.Jobs.Jobs and that is what in your error. You should wait for some time for Sitecore 9.2 compatible SPE module version. See below image for referencesenter image description here -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.