-1

I'm trying to duplicate my Sitecore installation from CM1 to CM2. After I completed my installation on CM1, I have applied the following steps:

  1. Copy wwwroot site folder from CM1 to CM2.
  2. Copy Solr indexes folders from CM1 to CM2
  3. Create new Website in IIS on CM2.

My new site is working fine except for Sitecore Experience Analytics.

Do you know if there is any other setting I should apply to resolve this issue?

enter image description here

  • Question 1: why? Question 2: Are you using the same databases? Did you copy the xConnect certificates from CM1 to CM2? – Chris Auer Jul 25 at 13:29
  • What are you trying to achieve here? A distributed CM environment or a new separate CM instance for a different website? – Richard Seal Jul 25 at 13:46
  • @ChrisAuer our goal is to have high availability environment. yes im using the same databases , for the Xconnect i export the certificate from CM 1 then i installed in CM 2 is there any other setting i should apply for the certificate ? – marwen1 Jul 26 at 15:41
  • @RichardSeal i try to have have high availability environment Incas if CM 1 down we can user CM 2 – marwen1 Jul 26 at 15:43
  • What is the error you are getting for the Experience Analytics on your new server sitecore instance – D S Jul 28 at 19:17
0

You could have a look at these below options for your new CM2 instance.

1) Please check the self-signed certificate has been installed in your new server. The SOLR instance is running up with the https certificate.

2) Your xconnect website https://xp0.xconnect/ should be running up with self signed https certificate.

3) Sometimes also seen that the xconnect website faces a trust issue due to the presence of non-self signed certificate in trusted root certificates in MMC. In power shell administrator mode try to run below command to check how many certificate are in trusted root folder .

PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject}

Try to move them to CA

PS C:\WINDOWS\system32> Get-Childitem cert:\LocalMachine\root -Recurse | Where-Object {$_.Issuer -ne $_.Subject} | Move-
Item -Destination Cert:\LocalMachine\CA

4) Type mmc and open your Certificate Store for 'Local Computer'. Right-click your Sitecore certificate > All Tasks > Manage Private Keys. Grant full control to both NETWORK SERVICE and IIS_IUSRS. Do it for both xp0.xconnect and xp0.xconnect_client certificates.

5) In IIS Manager check the certificate is set for xConnect websites. Set the correct certificate from the list for xconnect website. enter image description here

6) There might be certificate thumbprint value mismatched, please check xconnect and sitecore instance website certificate thumbprint value, try to place the correct thumbprint value in the intepub xconnect website App_Config folder appsetting.config , connectionstring.config and also in the sitecore app_config folder's config files . In case you have created a new certificate and their old certificate thumbprint values are present in that result it can show you an exception.

<add key="validateCertificateThumbprint" value="[CORRECT THUMBPRINT VALUE]" />
<add key="AllowInvalidClientCertificates" value="true" />
<add name="xconnect.collection.certificate" connectionString="StoreName=My;StoreLocation=LocalMachine;FindType=FindByThumbprint;FindValue=[CORRECT THUMBPRINT VALUE]" />

7) Check in the IIS xconnect application pool the identity is set to 'NETWORK SERVICE' also, the xconnect website SSL settings for the content of website or application require SSL checkbox is set to true and client certified is accepted

Finally also please check if there any internal/external network setting is applied which might be also blocked TSL/SSL secure channel communication.

Try to clear your browser cache and reload analytics dashboard.

0
  1. Is there any proxy that comes into the picture? I have faced such a situation where we had to add the XConnect URL to the Proxy By-pass, hence thought of sharing that info with you.
  2. Also, are you using App Pool Identity or a Network user in the App pool of the website. If you are using a Network User, you will need to add that user to the Certificate as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.