0

I have installed Sitecore 9.0 update 2 and am installing Sitecore Experience Commerce 9.0 update 3. I have SIF version 2.0.0 (I know it's not supported, but have worked around that issue already).

I am now getting the warning

Could not find Cert: DO_NOT_TRUST_SitecoreRootCert in cert:\LocalMachine\Root

followed by the error

Cannot validate argument on parameter 'Signer'. The argument is null, empty, or an element of the argument collection contains a null value. Supply a collection that does not contain any null values and then try the command again.

I got the warning after deleting the DO_NOT_TRUST_SitecoreRootCert certificate, and I wonder if this is causing problems, or can be ignored?

WARNING: Could not find Cert: DO_NOT_TRUST_SitecoreRootCert in cert:\LocalMachine\Root
Install-SitecoreConfiguration : Cannot validate argument on parameter 'Signer'. The argument is null, empty, or an
element of the argument collection contains a null value. Supply a collection that does not contain any null values
and then try the command again.
At C:\Program
Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.0.0\Public\Install-SitecoreConfiguration.ps1:641 char:25
+                         & $entry.Task.Command @paramSet | Out-Default
+                         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:01
Install-SitecoreConfiguration : Cannot validate argument on parameter 'Signer'. The argument is null, empty, or an
element of the argument collection contains a null value. Supply a collection that does not contain any null values
and then try the command again.
At C:\Sitecore\SitecoreExperienceCommerce903\SIF.Sitecore.Commerce.1.4.7\Deploy-Sitecore-Commerce.ps1:80
char:2
+     Install-SitecoreConfiguration @params
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:03
Invoke-NewSignedCertificateTask : Cannot validate argument on parameter 'Signer'. The argument is null, empty, or an
element of the argument collection contains a null value. Supply a collection that does not contain any null values
and then try the command again.
At C:\Program
Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.0.0\Public\Install-SitecoreConfiguration.ps1:641 char:47
+                         & $entry.Task.Command @paramSet | Out-Default
+                                               ~~~~~~~~~
    + CategoryInfo          : InvalidData: (:) [Invoke-NewSignedCertificateTask], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ParameterArgumentValidationError,Invoke-NewSignedCertificateTask
4

OOTB Sitecore XC installation needs a Root Certificate as it creates self-signed certificates for your storefront website. If you are planning to use different server certificates than OOTB self signed certificate, you can remove related tasks from installation script.

If you want to continue with default installation, you can do following: - check folder c:\certificates, your root certificate can be there, you can import it back from there. - you can create a new root certificate, in sitecore installation scripts modify "xconnect-createcert.json" file, keep tasks related to root certificate creation only and execute those steps.

After bringing the root certificate back, you can continue with Sitecore XC installation.

  • How would I make sure to only execute the certificate creation steps after modifying xconnect-createcert.json ? – Matthew Dresser Aug 1 at 9:57
  • 1
    Copy existing xconnect-cert.json file with different name, keep first 2 tasks and remove others. Copy your .ps1 file with different name, keep only one Install-SitecoreConfiguration command for your new xconnect-cert json file and remove others. execute your new .ps1 file. – Vipin Banka Aug 1 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.