0

I get a yellow-screen-of-death after clicking the Forms application icon from the launchpad:

The model item passed into the dictionary is of type 'Sitecore.Mvc.Presentation.RenderingModel', but this dictionary requires a model item of type 'Sitecore.Speak.Components.Models.Structures.Substructures.GlobalHeaders.GlobalHeaderRenderingModel'.

Screenshot of error

I found this other question that appears similar. A comment there suggests that this error could be caused by missing a step from the upgrade procedure. We did recently run through an upgrade to 9.0.1 from 8.1.0.

Any ideas where I might start looking to figure out this issue?

I am also a little confused as to where the file in question is. The path that the error message displays (/sitecore/shell/client/Business Component Library/version 2/Layouts/Renderings/Structures/Substructures/GlobalHeader.cshtml) for the Razor view does not even exist in my filesystem. I double-checked this against the provided Sitecore 9.0.1 files from the upgrade documentation, and sure enough, the file doesn't exist there either. There does not seem to be a Structures folder in the /sitecore/shell/client/Business Component Library/version 2/Layouts/Renderings directory.

  • Compare your files with those from a clean Sitecore install... that is normally the way to fix issues with these errors after upgrading – Gatogordo Aug 1 at 18:55
  • @Gatogordo Oof, that was tedious! I went through the entire application file structure and looked for file differences. Nothing in particular jumped out that looked related to this issue. Any other ideas? – BU0 Aug 6 at 18:16
  • Can you check /sitecore/client/Business Component Library/version 2/Layouts/Renderings/Structures/Substructures/GlobalHeader in the core database? The model should match Sitecore.Speak.Components.Models.Structures.Substructures.GlobalHeaders.GlobalHeaderRenderingModel,Sitecore.Speak.Components – Gatogordo Aug 6 at 18:36
  • That's getting closer; the model field was blank! I do believe this solved this particular error. I am getting further errors that look simliar to this The model item passed in..., but this seems to have solved this particular error. Thank you! If you create an answer, I'll be happy to mark it! – BU0 Aug 6 at 18:46
0

You should verify the items /sitecore/client/Business Component Library/version 2/Layouts/Renderings/Structures/Substructures/GlobalHeader (and related) in the core database. They have a model and it seems that those are not correct. The model for the GlobalHeader should match Sitecore.Speak.Components.Models.Structures.Substructures.GlobalHeaders.GlobalHeaderRenderingModel,Sitecore.Speak.Components.

If you keep getting these errors, try installing a blank Sitecore 9.0.1 and compare the core databases.

  • Thanks! I did end up grabbing a Core database from a working site and using that in my site. I am now able to see the forms application. – BU0 Aug 6 at 19:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.