1

Environment details: 9.0.2 XP0

What I am trying to do: I am trying to create an xConnect client from Sitecore context.

What is the issue I am facing:

The request was aborted: Could not create SSL/TLS secure channel.

enter image description here

Points I have checked: 1. Sitecore client is working with Https without any warning. enter image description here

  1. xConnect is opening with Https in browser properly. enter image description here

  2. The certificate thumbprint is according to the certificate applied in the Connection string of Sitecore client and App-config of xConnect. enter image description here

enter image description here

enter image description here

Please suggest what else I should check. Edit 1: Also checked at sc9u2.xconnect\App_data\jobs\continuous\AutomationEngine\App_Config\ConnectionStrings.config. The thumbprint value is same.

  • please check the sitecore instance application pool has full permission to access xconnect _Client certificate – D S Aug 2 at 15:04
  • @DS- I have provided access to Everyone over this certificate. – NutsAndBolts Aug 3 at 7:16
2

Two things.

  1. The valid thumbprint should be the thumbprint from sc9u2.xconnect_client certificate. The cert sc9u2.xconnect is the SSL cert for the site. The _client cert is the one being used to encrypt the message. Update your configs (sitecore and xconnect) to use the right certificate thumb print. Remember that if you copy the cert from certificate manager, it includes some special characters you can't see. echo it in powershell to get the real value without the hidden characters.

  2. Right click on sc9u2.xconnect_client and click Manage Private Keys. In the security popup, add the app pool user for your sitecore website. If this is dev, you can just add Everyone.

enter image description here

  • Thanks will check and revert. – NutsAndBolts Aug 2 at 19:35
0

Please make sure below things are in place.

1- Thumbprint iscorrect in xconnect app.config and CD/CM server's connectionstring.config files.

2- Make sure, you have given the permission for certificate in MMC for the user which is used in apppool.

3- xconnect certificates are installed in CD and CM Servers.

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.