3

My Sitecore rocks automatically updated on 8/1 and now opening items throw an error with the following message (see screen shot). Is there a workaround or something that needs to be reconfigured?

Sitecore Rocks error message dialog

8
  • 1
    I am also getting same error. I am using Sitecore Rocks 3.0.281 and Sitecore 8.1 Initial version. Aug 5, 2019 at 13:20
  • 1
    Sitecore 8.2.171121 and from the browser functions normal
    – jason
    Aug 5, 2019 at 13:55
  • 2
    I am the Product Manager for Rocks.... we are hearing reports of Rocks broken on 8.x instances. We are investigating and intend to release a fix ASAP. Aug 5, 2019 at 14:25
  • 1
    Jason and @jitendra-ghanekar and anyone else... could you try installing the VSIX from the build artifacts here and confirm whether it resolves the issue for you? dev.azure.com/sitecore-devex/Sitecore%20Rocks/_build/… Aug 5, 2019 at 18:07
  • 1
    @techphoria414 - Patch worked for me. Thanks Aug 6, 2019 at 6:47

1 Answer 1

1

The quick answer is now that this has been resolved in Sitecore Rocks 3.0.283, which should auto-update from the VS Marketplace or can be downloaded on GitHub.

The details are that there was an issue in the 3.0.281 release of Sitecore Rocks which caused a MissingMethodException in Sitecore.Diagnostics.Log when run against Sitecore 8.x. Sitecore Rocks 3.0 is built against Sitecore 9.1, which adds overloads to the Log class to discourage incorrect use (passing in an Exception without an owner). Rocks had such an incorrect use which was not fixed on release, so when executed against Sitecore 8.x, the overload was not available.

You can see the fix in this commit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.