0

I am having some trouble creating a new Sitecore Form. I am able to launch the Forms app. But when I click the blue Create button and select Blank form, the page loads for a second and then displays an error: The form was not loaded due to an error.

enter image description here

I did some snooping, and found that around the time the page switches to the error mode there is a 404 error being returned for an API request to http://mydomain.localhost/formbuilder/load?id=&sc_formmode=new&sc_formlang=&_=1565192173806. Tracked that down to a call from a Javascript file http://mydomain.localhost/-/speak/v1/components/FormDesignBoard.js.

enter image description here

Any ideas what could be causing this error? I found this other question that seems similar, though their error reports a 401/403 while my AJAX request definitely returns a 404. I tried their recommendation to add the sitecore/Forms Editor role to my Administrator user, but no luck. Still get the same 404 result. Even tried logging out/in again and rebooting my local server after altering my user roles.

As referenced in my previous question, I am running Sitecore 9.0.1 r171219 that we upgraded from Sitecore 8.1.0 r160302. It is quite possible that something did not get upgraded properly, but I am at a loss as to where to look.

I tried swapping my Core database for the stock Core Sitecore database provided in the 9.0.1 release, but still received the same error.

I've also gone through the filesystem and compared my site structure to the stock Sitecore file structure. There were differences, but they were ones that I expected to see; nothing jumped out at me as being related to Forms functionality.

Edit: Log files show nothing of interest, sadly.

Have now also commented out a couple httpRequestBegin pipelines to see if they were the cause. No luck -- still same 404 error.

Anyone have any ideas on other things to look at?

9
  • Have you checked your log files for errors related to this?
    – Richard Seal
    Commented Aug 7, 2019 at 17:44
  • do you have any rewrite module or a custom processor in the httpBeginRequest pipeline? check your custom implementation especially which are related to requests. Commented Aug 7, 2019 at 17:50
  • @RichardSeal I did check the logs! Nothing interesting there, unfortunately.
    – BU0
    Commented Aug 7, 2019 at 17:57
  • @TamásTárnok Perhaps something to consider there. We are using the Sitecore.MultisiteHttpModule.NotFound.NotFoundHandler.
    – BU0
    Commented Aug 7, 2019 at 17:59
  • @BU0 try to disable this module and see if this the root of the issue. Commented Aug 7, 2019 at 18:02

1 Answer 1

0

I believe this was caused by a poor Sitecore 9.0.1 upgrade. I ended up installing a fresh 9.0.1 site, and then migrating my content & code over to that. Forms area is working now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.