3

We identify many repetitive warnings into Sitecore log files:

WARN  Failed to create counter 'Sitecore.Analytics.XConnect\XConnect Model Converter | Convert To XConnect Interaction Operations / sec'. Sitecore has no necessary permissions for reading/creating counters.
        Message: Access to the registry key 'Global' is denied. 

It seems permission issue. Please assist.

2

Sitecore Version: 9.2

We need to add our website's IIS AppPool user to “Performance Monitor Users” group.

Please follow below steps to clear this warning.

Go to Computer Management
System Tools -> Local Users and Groups -> Groups -> “Performance Monitor Users” group and open it’s properties.

Click on “Add” button and add your IIS AppPool user for your site e.g. “IIS APPPOOL\sc92sc.dev.local”.

Here sc92sc.dev.local is my local website name.

enter image description here

Reference: https://tothecore.sk/2018/06/12/setting-permissions-for-reading-creating-counters-in-sitecore-9/

2

Another easy way to achieve the same is-

  • Run Command prompt as administrator and execute below command:

    CMD> net localgroup “Performance Monitor Users” SitecoreInstanceName/add

In your case it would be like:

C:\WINDOWS\system32> net localgroup "Performance Monitor Users" sc92sc.dev.local/add

execute this command and it will add your website's IIS AppPool user to Performance Monitor Users group.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.