1

Installing Sitecore Commerce (Sitecore.Commerce.2018.07-2.2.126) on the server. I am executing the below script Bootstrap-Commerce-Engine.ps1

#Requires -Version 3
param(
)
#Initializes Global Parameters
.\Global-Config
$global:DEPLOYMENT_DIRECTORY=Split-Path $MyInvocation.MyCommand.Path
$modulesPath=( Join-Path -Path $DEPLOYMENT_DIRECTORY -ChildPath "Modules" )
if ($env:PSModulePath -notlike "*$modulesPath*")
{
    $p = $env:PSModulePath + ";" + $modulesPath
    [Environment]::SetEnvironmentVariable("PSModulePath",$p)
}

$params = @{
        Path = Resolve-Path '.\Configuration\Commerce\CommerceEngine\CommerceEngine.Bootstrap.json'
        CommerceOpsServicesPort = "5015"
        CommerceOpsService = $CommerceOpsService
        SitecoreAdminAccount = @{
            userName = $SitecoreUsername
            password = $SitecoreUserPassword
          }
        UrlIdentityServerGetToken = "$($CommerceIdService):5050/connect/token"
    }
Install-SitecoreConfiguration @params -Verbose

getting the error:

[---------------------------------------- GetIdServerToken : GetIdServerToken ----------------------------------------]
Get Token From Sitecore.IdentityServer - Uri: https://tmpqa-id:5050/connect/token Body: System.Collections.Hashtable
VERBOSE: POST https://tmpqa-rb-id:5050/connect/token with -1-byte payload
>> TerminatingError(Invoke-RestMethod): "The remote server returned an error: (500) Internal Server Error."
>> TerminatingError(Invoke-RestMethod): "The remote server returned an error: (500) Internal Server Error."
Install-SitecoreConfiguration : The remote server returned an error: (500) Internal Server Error.
At C:\deploy_xc\Bootstrap-Commerce-Engine.ps1:29 char:1
+ Install-SitecoreConfiguration @params -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
Install-SitecoreConfiguration : The remote server returned an error: (500) Internal Server Error.
At C:\deploy_xc\Bootstrap-Commerce-Engine.ps1:29 char:1
+ Install-SitecoreConfiguration @params -Verbose
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration

[TIME] 00:00:01
**********************
Windows PowerShell transcript end
End time: 20190813104830
**********************
  • 1
    please check logs in identity server and see if there are more details? – Vipin Banka Aug 13 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.