0

I tried Sitecore XC 9.2 installation and found following issues on my machine:

  1. During the installation, Visual Studio Just-In-Time Debugger window got popped up several times, every time i just selected "No, cancel debugging" option to continue. enter image description here

  2. During Bootstrap, RunMinion and Generate Catalog Templates installation steps i found below Application startup exception in commerce engine service

00001 23:16:24 INFO Application startup exception
System.InvalidOperationException: Unable to resolve service for type 'Microsoft.AspNetCore.ResponseCompression.IResponseCompressionProvider' while attempting to activate 'Microsoft.AspNetCore.ResponseCompression.ResponseCompressionMiddleware'.
   at Microsoft.Extensions.Internal.ActivatorUtilities.ConstructorMatcher.CreateInstance(IServiceProvider provider)
   at Microsoft.AspNetCore.Builder.UseMiddlewareExtensions.c__DisplayClass4_0.b__0(RequestDelegate next)
   at Microsoft.AspNetCore.Builder.Internal.ApplicationBuilder.Build()
   at Microsoft.AspNetCore.Hosting.Internal.WebHost.BuildApplication()

To resolve the issue, i disabled the compression setting in all commerce engine configuration files at below locations:

  • CommerceAuthoring\wwwroot\config.json
  • CommerceMinions\wwwroot\config.json
  • CommerceOps\wwwroot\config.json
  • CommerceShops\wwwroot\config.json

Restarted IIS AppPool and then continued with installation.

I want to know what should be done to avoid above issues during installation?

0

Were the w3wp crashes during installation of Sitecore modules?

They looks very similar to this xConnect crash KB: https://kb.sitecore.net/articles/494291

If you are on a Windows 10 build older than 1809, could you try installing the ".NET Framework November 2018 Security and Quality Rollup" as mentioned in the KB solution?

If you are on Windows 10 1809 or newer, could you try the binding redirect workaround in your Sitecore instance?

Before:

<dependentAssembly>
    <assemblyIdentity name="System.Security.Cryptography.Algorithms" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" xmlns="urn:schemas-microsoft-com:asm.v1" />
    <bindingRedirect oldVersion="0.0.0.0-4.3.0.0" newVersion="4.3.0.0" xmlns="urn:schemas-microsoft-com:asm.v1" />
</dependentAssembly>

After:

<dependentAssembly>
    <assemblyIdentity name="System.Security.Cryptography.Algorithms" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" xmlns="urn:schemas-microsoft-com:asm.v1" />
    <bindingRedirect oldVersion="0.0.0.0-4.3.0.0" newVersion="4.0.0.0" xmlns="urn:schemas-microsoft-com:asm.v1" />
</dependentAssembly>
  • Yes i can see w3wp crash entries in windows event viewer. My windows version is 1803 so i will try installing ".NET Framework November 2018 Security and Quality Rollup". Will this also resolve the "Application Startup" issue in commerce engine service that i mentioned above? – Vipin Banka Aug 15 at 12:12
  • I doubt it will help for the Commerce Engine issue. I have no clue for this one. – Jean-François L'Heureux Aug 16 at 14:33
  • Sitecore just updated the KB article to cover more than xConnect: kb.sitecore.net/articles/494291 – Jean-François L'Heureux Aug 20 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.