2

I have a Sitecore 8.2 site. WebDav is disabled on the CD as per

https://doc.sitecore.com/developers/82/sitecore-experience-platform/en/disable-webdav.html#

by disabling the Sitecore.WebDAV.config.

But the error logs are still full of this error:

7848 03:18:25 ERROR Application error.
Exception: System.NotSupportedException
Message: Unknown request type: PROPFIND
Source: Sitecore.Mvc
at Sitecore.Mvc.Helpers.WebHelper.GetRequestType(HttpContextBase httpContext)
at Sitecore.Mvc.Pipelines.Request.RequestBegin.ExecuteFormHandler.Process(RequestBeginArgs args)
at (Object , Object[] )
at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
at Sitecore.Mvc.Pipelines.PipelineService.RunPipeline[TArgs](String pipelineName, TArgs args)
at Sitecore.Mvc.Routing.RouteHttpHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Which I think is a WebDAV error. Do I need to do something else to disable WebDAV? Or os this error from something else?

  • There are a couple of WebDav handlers in web.config. The docs used to state to disable these too, but the latest doc does not mention this... you could try commenting these out too. – jammykam Aug 17 '19 at 3:14
  • Here is nice article it may be helpful. sitecoresysadmin.wordpress.com/2017/09/01/… – Ercan Polat Aug 17 '19 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.