0

Using Sitecore 8.2, when I add a mailto:link it gives me a validation error that external links require a target. However, the modal tab for mailto links doesn't contain a target field, and if I insert something into the Hyperlink tab it either ignores it or uses just the fields on that tab - ie it won't seem to pull from multiple tabs - this is when I confirm by going into edit html. I'm wondering if there is any way of doing this other than manually editing the html or am I just missing something?

0

When you insert a link via the Hyperlink Manager you should have an Email tab. When you use this tab, the correct link <a href="mailto:info@address.com">Email me</a> will be generated. See also the documentation: https://doc.sitecore.com/users/82/sitecore-experience-platform/en/insert-a-link-in-a-text-field.html

enter image description here

  • Yes, but part of the problem is that the external link validation rule is getting activated because this mailto link does not have a target. I can remove the validation rule (I have) but I find it odd that the UI creates html that is then flagged by this validation rule... – Levi Wallach Aug 21 '19 at 12:01
  • @LeviWallach that is indeed odd. Another workaround is to first use the Hyperlink tab to set a link with a fake url and a target. Then you should edit the link again but now use the E-Mail tab to set the emailaddress. The previously set target will remain in the HTML while the url gets changed to the mailto:addres value. The External Link Validator checks whether a targer OR a title (tooltip) has been set. – Mathijs Vlasveld Aug 22 '19 at 6:27
  • Yeah, since this is something that the customer needs to use, it seems not worth it if we need to instruct them to do this... Thanks. – Levi Wallach Aug 22 '19 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.