0

I've been asked by my client to disable content testing in Sitecore, as it will not be used in the near future and the hope is disabling it will improve site performance.

I've searched the documentation and other articles, and the following config would seem to do what I'm asking:

<!--
  Following configuration is to disable A/B testing on site to improve performance
-->
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <group name="itemProvider" groupName="itemProvider">
      <pipelines>
        <getItem help="Processors should derive from Sitecore.Pipelines.ItemProvider.GetItem.GetItemProcessor.">
          <processor type="Sitecore.ContentTesting.Pipelines.ItemProvider.GetItem.GetItemUnderTestProcessor, Sitecore.ContentTesting" >
            <patch:delete />
          </processor>
        </getItem>
      </pipelines>
    </group>
    <settings>
      <setting name="ContentTesting.AutomaticContentTesting.Enabled" value="false" >
        <patch:attribute name="value">false</patch:attribute>
      </setting>
    </settings>
  </sitecore>
</configuration>

However, the issue I'm having is the patch:delete doesn't seem to work; when I check the compiled configuration, the processor entry is still there. The ContentTesting.AutomaticContentTesting.Enabled setting patch is applied, though.

So my questions are:

  1. Given that I'm trying to improve performance, is this the correct way to go about it with Sitecore 9.0.1?

  2. If so, why isn't my patch:delete statement working?

As I said, I'm using Sitecore 9.0.1.

1

You're missing one <pipelines> node around <group>:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
  <sitecore>
    <pipelines>
      <group name="itemProvider">
        <pipelines>
          <getItem>
            <processor type="Sitecore.ContentTesting.Pipelines.ItemProvider.GetItem.GetItemUnderTestProcessor, Sitecore.ContentTesting" >
              <patch:delete />
            </processor>
          </getItem>
        </pipelines>
      </group>
    </pipelines>
    <settings>
      <setting name="ContentTesting.AutomaticContentTesting.Enabled" value="false" >
        <patch:attribute name="value">false</patch:attribute>
      </setting>
    </settings>
  </sitecore>
</configuration>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.