4

I am getting the error "Failed to start the Marketing Automation Engine service" - While installing Sitecore 9.2 on my local machine via Sitecore Install Assistant (SIA). I have installed SOLR 7.5 and it is running perfectly fine. I also have installed all the prerequisite by SIA itself.

Below is the screenshot attached for reference :-

enter image description here

I have checked the logs and found different error on different time stamp.

[Error] Error initializing XConnect client.
System.AggregateException: One or more errors occurred. ---> Sitecore.XConnect.XdbCollectionUnavailableException: The HTTP response was not successful: Forbidden
   at Sitecore.XConnect.Client.WebApi.ConfigurationWebApiClient.<Refresh>d__6.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.XConnect.Client.XConnectClientConfiguration.<InitializeAsync>d__32.MoveNext()

[Error] Failed to start the Marketing Automation Engine service.
System.InvalidOperationException: This configuration has not been initialized. Please call the initialize method before using it.
   at Sitecore.XConnect.Client.XConnectClientConfiguration.CheckInitialized()
   at Sitecore.XConnect.Client.XConnectClientConfiguration.get_CurrentModel()
   at Microsoft.Extensions.DependencyInjection.ServiceLookup.CallSiteRuntimeResolver.VisitScoped(ScopedCallSite scopedCallSite, ServiceProviderEngineScope scope)
   at Microsoft.Extensions.DependencyInjection.ServiceLookup.DynamicServiceProviderEngine.<>c__DisplayClass1_0.<RealizeService>b__0(ServiceProviderEngineScope scope)

I have tried to start service manually but again getting below shown error :-

enter image description here

Getting few error in event viewer as well as shown below :-

enter image description here

enter image description here

enter image description here

Earlier I was able to install Sitecore 9.2 with the same steps which I have followed. But this time I have been stuck at this error. I have tried clearing the incomplete instance of Sitecore 9.2 once and the reinstalling again after restarting my laptop but no luck so far.

Did any one faced this issue or have any idea about this issue?

3
  • 1
    Marketing automation service needs a connection with xConnect so check the connection string file for automation service and see the xConnect url is correct and it is working. I got same error once when my bindings for xConnect service were wrong and IIS website for xConnect was not started. Aug 28 '19 at 13:48
  • @VipinBanka I am wondering while installing Sitecore via SIA doesn't have any manual interference. So how come the connection string creates the issue here. Although I have checked the xConnect url is correct and xConnect site is working fine.
    – SumitK
    Aug 29 '19 at 3:59
  • the point is that marketing automation service needs xConnect up and running, specifically it needs to interact with xConnect collection role, it keeps connection details inside connection string file ({your-xconnect-website-root}\App_Data\jobs\continuous\AutomationEngine\App_Config\ConnectionStrings.config), the error you mentioned above says "Error initializing XConnect client" that is why i suggested you to verify things, other thing you can check is, verify correct user permission are setup on your xconnect certificate. Aug 29 '19 at 4:30
0

Make sure ASP.NET 4.7 is enabled for development in IIS server in Windows features. All the below highlighted features should be checked.

enter image description here

For more details, you can check out this post: https://www.linkedin.com/pulse/sitecore-93-local-installation-raman-gupta/

0

We had similar issues installing Sitecore 9.2 XP on local machine running 2016. The only solution that worked for us is updating the user permission on inetpub folder.

Steps we followed to fix the issue

  1. Removed all the databases from SQL server for the instance created
  2. Delete the folders created in inetpub folder
  3. removed all the services (by stopping some of the background services running)
  4. Update the permissions on inetpub folder to give full control for all users (this is temp step, please revert it back once installation is successful)
  5. Install Sitecore 9.2 again

This should install without any issues.

Make sure you change the permissions after installation is done.

0

Another reason that can cause the error in starting the Marketing service is the Sitecore License expiration. We were facing that issue, after using a valid license it worked fine. You can verify this in the IIS folder xconnect\App_Data\jobs\continuous\AutomationEngine\App_Data\license.xml

0

Sometimes, if you have tried the installation script more than once, you can have some undesired behavior. Like some said before, you are possibly trying to go forward with the wrong certificates. Also, some of these services were actually created on previous installation attempts.

Here is what I think should help you get through.

Clean your workspace

  • Remove your databases that are related to the installation if exists.
  • Remove your certificates (using certlm -> you can type in your windows search bar "cert" and then you should be able to pick "Manage computer Certificate".
    • On the left sidebar, Click on Personal > Certificates.
      • Remove your installation-related certificates
        • nameOfYourInstallation.identityserver
        • nameOfYourInstallation.sc
        • nameOfYourInstallation.xconnect
  • Open your Windows Services Manager (you can type in your windows search bar "services" and select the services app)
    • You should be able to see those services :
      • Sitecore Marketing Automation Engine - nameOfYourInstallation(might be one of your previous install)
      • Sitecore Processing Engine - nameOfYourInstallation
      • Sitecore XConnect Search Indexer - nameOfYourInstallation.
        • Write those down. Keep your service app open.
    • Using NSSM (probably installed already from some of your previous installed, if not, can use chocolatey ( https://chocolatey.org/packages/NSSM ) remove those services.
    • in a cmd : nssm remove serviceName
      • Note that you can remove them by right clicking etc. I just prefer the nssm way.
  • When its done, restart your computer (some services and in a state of removal, that needs a restart to be completely removed)
  • Try to install with SIA again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.