0

I've installed Sitecore Powershell Extensions version 5.0 on Sitecore 8.2 update 7, I also installed Microsoft.Management.Infrastructure as it was a dependency. I installed this library through NuGet and then added a reference to it in my Visual Studio project. After publishing to my local site I get this error when trying to access Sitecore:

Could not load file or assembly 'Microsoft.Management.Infrastructure' or one of its dependencies. Strong name signature could not be verified. The assembly may have been tampered with, or it was delay signed but not fully signed with the correct private key.

I'm not sure where the problem is. Anyone have any ideas?

I'm on a Win7 platform running IIS.

  • 1
    Have you tried installing Windows Management Framework 5.1 on the Windows 7 machine? – Michael West Aug 28 at 15:16
  • I wasn't aware that was a requirement. It should be mentioned in the GitBook and the Marketplace. I'll do that install and see if that fixes it. – Necromancer Aug 28 at 15:27
  • 2
    The book does in fact document here doc.sitecorepowershell.com/installation that the Windows Management Framework 3+ is required. I recommend you use the latest version supported for Windows 7 since it comes with many improvements for PowerShell. – Michael West Aug 28 at 15:47
  • @MichaelWest thanks, I must've missed it somehow. I stand corrected. This worked by the way. – Necromancer Aug 28 at 16:02
1

Since you are using Windows 7 my best guess is the issue relates to the fact that your OS does not have Windows Management Framework 3 or newer.

You can read more about that requirement here: https://doc.sitecorepowershell.com/installation

Simply install WMF 3 (preferably 5.1) and then everything should work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.