1

I am using sitecore 9.1.1 with SXA 1.8 installed. I have created a simple contact form using form extensions (By Bart verdonck).

However, the form gets displayed partially(all input tags of type='text' and labels does not show up) on the published page. See the below figure 1 enter image description here

I can see some issues in console , but it is not much clear as they are objecting the other fields of form to display.

However, when i open that form in Experience Editor, the form is visible. See Figure 2 enter image description here

The sad thing is that the same form with the same setup is displaying on local machine even though console has the same error.

What I have done till now to fix it but in vain?

  1. Added the functions explicitly (Html.RenderFormStyles() Html.RenderFormScripts()) in the formbuilder/Form.cshtml file.
  2. Modified the sxalayout.cshtml file and modified the function which is called for the form.

I have also gone through the listed links

  1. http://achievecreative.com/articles/jquery-is-not-defined-when-you-are-using-sitecore-91-form-with-sxa

  2. jQuery not defined error on sitecore 9.1.1 forms submission

and few more links too.. but no lucks...

Any idea why the form isn't displaying?

4
  • did you tried to inspect your form and check the HTML (of your remaining form elements) is rendering or not ? Aug 29 '19 at 10:55
  • @SunilKumar Yes, I did inspect the html, the input tags are not rendered, however as you see in the image, labels are rendered..
    – Varun
    Aug 30 '19 at 4:55
  • 1
    The issue got fixed by placing the files of the sitecore form extension module(files folder when we extract the sitecore form extension zip file) manually on the CD server.
    – Varun
    Aug 30 '19 at 13:03
  • Ok Great varun ! Aug 30 '19 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.