0

I have a Sitecore Identity Server (XP 9.1) running behind a Nginx reverse-proxy. The reverse-proxy handles the TLS encryption. Behind the reverse-proxy there is only HTTP traffic, so I added a HTTP web binding to the Identity Server:

New-WebBinding -Name identity -HostHeader '*' -IPAddress * -Protocol 'http' -Port 80

When I perform a Invoke-WebRequest from the Sitecore CD/CM server the external HTTPS address is reachable. Also the Identity Server is reachable from extern using HTTPS.

But when I try to login to the Sitecore CM server, it does not redirect to the Identity Server, and shows the login fallback (i.e. not using the ID server). There are no errors in the logs (Sitecore CM/CD and Identity Server).

When I invoke https://identity/.well-known/openid-configuration it returns HTTP urls instead of HTTPS. Might this be causing my problem?

I am missing some config setting?

1

Turns out Sitecore Identity Server 9.1 does not support reverse-proxies.

I created a small plugin to enable reverse-proxy support for it: https://github.com/joostmeijles/Sitecore.Identity.ProxySupport

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.