6

I'm encountering a little issue :

=> When I export my theme then edit it and then import it back the CSS modifications do not apply in the Experience Editor (event after opening the editor again, iisreset etc...)

=> But when I publish my website the correct CSS is applied

I checked if there was multiple versions of the Stylesheet in the media library but that's not the case.

It seem that the Experience Editor keeps showing the first version of the theme I imported back and when I use the Export feature it generates a corrupt CSS file containing the following HTML lines at the end :

Wrong lines[1]

But it seems to be the lastest version of the problematic CSS file.

I'm using Sitecore 8.2 rev. 160729 and Sitecore Experience Accelerator 1.1 rev. 161004 for 8.2.

9
  • Could you tell us what appears in summary dialog after you imported the theme? Is there something like (media item created/updated) and the corresponding path? Also could you check if the item that is published and supposed to be working is the same as the item which doesn't work (compare item ID). And when you publish and is starts working where? In Experience Editor Preview or on publish, viewing web database content? – Alan Płócieniak Nov 3 '16 at 16:00
  • Try removing optimize-min (after import) items which should be present in each of the media folders in your theme. And let me known if this will help! If yes then we might have a bug and I will take a look at this problem. – Dawid Rutkowski Nov 4 '16 at 6:50
  • I don't see any optimize-min file in the style folder. – Aloys Nov 4 '16 at 10:34
  • I think that my problem comes from 2 underlying issues : – Aloys Nov 4 '16 at 11:17
  • => There is browser cache on stylesheet – Aloys Nov 4 '16 at 12:44
6

You should be able to see the 'preview' of the page working as expected before sending content to production. With that said, this seems to be more like a code related issue rather than a cache problem.

To investigate CACHING issues please please try these suggestions:

  1. Open your domain/sitecore on a private browser (incognito mode). This will disable browsing history and the web cache.

  2. Clear your Sitecore cache. Access youdomain/sitecore/admin/cache.aspx page. This page displays details about the caching settings configured. This includes database prefetch, data cache, item cache, HTML cache, etc.

To Investigate issues on the Experience Editor please try these suggestions:

  1. Open your experience editor and use the Browser Inspector. Go to DEBUG tab on Firefox (or SOURCE on Chrome), select your CSS file and verify if the content of your latest CSS is being load it.

  2. Check the CONSOLE tab on the inspector and see if your page loads without errors.

I hope that helps you to investigate this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.