0

I am using Sitecore 8.2 update 7 version. What ever content we are adding/modifying and publishing. Changes are not reflecting on site. But changes can see in web DB. After IIS App pool recycles, changes are reflecting on site.

Site is deployed On-Premises, Not sure whether CM and CD sites are on the same server. It's happening in the Staging environment.

Checked below checklist

  1. EnabledEventQueue is true in Sitecore.config
  2. Added handler for Sitecore.Publishing.HtmlCacheClearer for publish:end and publish:end:remote events.
  3. ScalabilitySettings.config is enabled on both CM and CD.
  4. Checked Scalability guide, All checklist has been taken care.

But still not sure what would be the issue. Please help me to solve this issue.

Any suggestion is most appreciated!!.

5
  • Are you clearing the HTML caches for the relevant sites? – Mark Cassidy Sep 13 '19 at 8:36
  • Yes Mark , I am doing that using sitecore admin page. – user2576426 Sep 13 '19 at 9:36
  • Have you tried clear the sitecore cache manually from the cache.aspx page on CD? – Hishaam Namooya Sep 13 '19 at 20:40
  • Is your data coming from search indexes? Is it coming by Sitecore API? Do you have other type of caching like Item or Data Cache? – Mohammed Syam Sep 17 '19 at 0:41
  • Hi Mohammad, I have used one custom index to list and search the products its working fine. Using Sitecore api to fetch the content from respective db. Not used any custom caching mechanism – user2576426 Sep 17 '19 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.