0

I am getting below error while installing sitecore 9.01.

Error Code: ERROR_APPPOOL_VERSION_MISMATCH More Information: The application pool that you are trying to use has the 'managedRuntimeVersion' property set to ''. This application requires 'v4.0'. Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_APPPOOL_VERSION_MISMATCH.

In application pool xconnect status is stopped and .net clr version is no managed code.

1

So set your app pool to use .CLR Runtime 4.0, as the message says.

enter image description here

1

If you are installing this via Sitecore Install Framework (SIF), then you can add a ManagedRuntimeVersion property to the CreateAppPool task in the JSON config file.

Here is an example:

"CreateAppPool": {
    "Description": "Create or updates the app pool.",
    "Type": "AppPool",
    "Params": {
        "Name": "[parameter('SiteName')]",
        "Properties": {
            "ProcessModel": {
                "identityType": "ApplicationPoolIdentity"
            },
            // Add or update this proptery to "v4.0"
            "ManagedRuntimeVersion": "v4.0"
        }
    }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.