4

I am seeing this strange behavior in sitecore CM. Recently, I am not able to login to sitecore. When I use the correct username and password, sitecore just refreshes and the login page is shown again. Please find the fiddler trace below for the same.

Based on the fiddler logs , it looks like a redirect is causing the issue. I checked the redirect config, but I don’t see any specific entry for sitecore. If I give a wrong username and password, error message is thrown as expected. Can you please guide me on this. Fiddler Trace:

8
  • Do you have any custom redirect rules on your IIS? Commented Nov 3, 2016 at 22:08
  • Did you override any pipeline for processing requests? Commented Nov 3, 2016 at 22:14
  • Do you have any cookies from other sites that share a cookie domain? If so simply clear all your cookies.
    – Joe Bissol
    Commented Nov 3, 2016 at 22:16
  • Have you recently added/modified any pipelines? Or perhaps back track the changes prior to this happening?
    – Jacky Lau
    Commented Nov 3, 2016 at 22:18
  • @AlanPłócieniak - We dont have a custom redirect rules at the IIS level.
    – Karthik
    Commented Nov 4, 2016 at 3:45

4 Answers 4

6

One reason for this behavior may be having an httpCookies domain setting in web.config that doesn't match the domain you are using to login to the Sitecore client, or having httpCookies requireSSL set to true while login in on http instead of https.

1
  • Hi @Ben Verhees, Thanks for the input. The issue was due to setting "requireSSL" attribute = true from httpCookies tag in web.config. Previous value:<httpCookies requireSSL="true" httpOnlyCookies="true"/> Changed Value:<httpCookies httpOnlyCookies="true"/> Our server infrastrutucture team has made some changes due to which this issue has occured. we reached out to them and they reverted the changes from their side.
    – Karthik
    Commented Dec 27, 2016 at 4:04
0

I saw this behavior once, it turned out that the authentication entry in my Web.config had been changed. I think it had been set to mode="Forms", which Sitecore doesn't like.

1
  • This works in most cases. In our case, the issue was due to the setting "requireSSL" attribute = true from httpCookies tag in web.config.
    – Karthik
    Commented Dec 27, 2016 at 4:11
0

This happened to me once on Chrome so I moved to another browser which worked fine (firefox). I later learned that clearing the cookies (and maybe cache on Chrome) could fix the problem.

1
  • I tried in a different browser(incognito/private) as well. It did not help.
    – Karthik
    Commented Nov 8, 2016 at 16:34
0

Not sure if this qualifies as a new answer I apologies but the following things are possibilities to check... If mentioned before, at least consolidated here.

  1. Clear cookies/ try new browser
  2. Disable any redirect to rewrite rules in your web config.
  3. Disable any error page logic

When this has happened to me in the past its been one of the three above that gets me back in business.

Not the answer you're looking for? Browse other questions tagged or ask your own question.