2

Following the Sitecore documentation, if Sitecore.Analytics.Lookups.IpHashProvider is set then the IP addresses will be in hashed. My configuration file contains value as below:

<add name="default" salt="f54RYb4RT4ylVC" type="Sitecore.Analytics.Lookups.IpHashProvider, Sitecore.Analytics" />

But if I query my database using the following query:

SELECT InteractionId, LastModified, IpAddress, Country, City, Latitude, Longitude
  FROM [Prod_Xdb.Collection.Shard0].[xdb_collection].[InteractionFacets]

  CROSS APPLY OPENJSON (FacetData)
    with (
      IpAddress nvarchar(max) N'$.IpAddress', 
      Country nvarchar(max) N'$.Country', 
      City nvarchar(max) N'$.City', 
      Latitude nvarchar(max) N'$.Latitude', 
      Longitude nvarchar(max) N'$.Longitude'                     
    )

  WHERE FacetKey = 'IpInfo'

Then I can see the ip addresses stored in clear text, data such as 10.11.120.8 which is not hashed.

Is there a different configuration that needs to be set?

3
  • are you getting all the data like this or some data like this? Commented Sep 17, 2019 at 7:09
  • External PII Ip will be hashed. This looks like internal communication inside your solution.
    – Mark Cassidy
    Commented Sep 17, 2019 at 7:48
  • Yes all the IP are shown in clear text.
    – tpkphani
    Commented Sep 20, 2019 at 10:44

1 Answer 1

2

I have asked Sitecore the same question and their answer as below:

In the InteractionFacets table of collection database, the real IPs are stored when Analytics.RedactIpAddress setting is set to false and the 0.0.0.0. IPs are stored when the setting is set to true.
The hashed IPs are stored in the ReferenceData database. In the ReferenceData database, they are always hashed. Unfortunately, the article that you refer is not mentioned that. I've made a request to correct it. Thank you for reporting that. Actually, In Sitecore 8 there was the same logic but - https://doc.sitecore.net/sitecore_experience_platform/82/setting_up_and_maintaining/xdb/contacts/ip_address_hashing*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.