0

Working with Sitecore 9 (Update 1), SXA 1.7.1 and Azure Search.

Components added on the page: Map, Location Finder, Search Results (all components have the same search signature).

enter image description here

Search Query:

https://mylocal.com/fr/sxa/search/results/?l=fr-FR&s={1AB997C8-36F9-4A14-81CD-02801D89B7CF}&itemid={839D6B67-A046-4E84-9F12-6E1BDDB4197C}&sig=&autoFireSearch=true&v={0EA6CE1F-3008-4783-95BF-E550C4CC2182}&p=20&g=48.856614|2.3522219000000177&o=Distance,Ascending&site=mylocal

Log:

Exception: Sitecore.ContentSearch.Azure.Http.Exceptions.BadRequestException
Message: Error in the request URI, headers, or body
Source: Sitecore.ContentSearch.Azure
   à Sitecore.ContentSearch.Azure.Http.SearchServiceClient.EnsureSuccessStatusCode(HttpResponseMessage response)
   à Sitecore.ContentSearch.Azure.Http.SearchServiceClient.Search(String expression)
   à Sitecore.ContentSearch.Azure.Http.CompositeSearchService.Search(String expression)
   à Sitecore.XA.Foundation.VersionSpecific.Search.Azure.LinqToCloudIndex1.Execute(CloudQuery query, Int32& countDoc, Int32& totalDoc, Dictionary2& facetResult)
   à Sitecore.XA.Foundation.VersionSpecific.Search.Azure.LinqToCloudIndex`1.ExecuteTResult
   à Sitecore.XA.Feature.Search.Controllers.SearchController.GetResults(String v, String q, String s, String l, String g, String o, Int32 e, Int32 p, String sig, String site, String itemid)

Nested Exception

Exception: Sitecore.ContentSearch.Azure.Http.Exceptions.AzureSearchServiceRESTCallException
Message: {"error":{"code":"","message":"Invalid expression: Unrecognized 'Edm.Geography' literal 'geography'Point(2,2908303 48,8870341)'' at '26' in 'geo.distance(geolocation, geography'Point(2,2908303 48,8870341)') lt 200' with reason 'Expecting token type \"Number\" with text \"\" but found \"Type:[7] Text:[,]\".'.\r\nParameter name: $filter"}}
  • Can you try updating to SXA 1.8, 1.8.1 or the best to 1.9? I remember that we did a lot of changes in Azure Search logic in 1.7 and 1.7.1 due to the platform (Sitecore) changes. Right now everything is working fine. – Dawid Rutkowski Sep 20 at 10:31
  • @DawidRutkowski For the moment, the issue is we do not want to update the SXA. Is there any way to fix it in the current version? – PSS Sep 20 at 11:34
  • I won't find time to check it on such an old version without a Support Ticket. – Dawid Rutkowski Sep 20 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.