3

To prevent duplicate items in Sitecore I used the following setting

 <setting name="AllowDuplicateItemNamesOnSameLevel" value="false" patch:instead="*[@name='AllowDuplicateItemNamesOnSameLevel']">
      </setting>

This setting is not allowing emails to get triggered(using sitecore 9 forms and exm for forms and emails on submit button click).If I remove this setting then emails are triggering. Can somebody please help?

  • 1
    It would be good to create a Sitecore support ticket for this, in past I also face some package installation related issue after disabling this setting in version 8. – Mahendra Shekhawat Sep 18 at 13:58
1

Have you checked final values for this settings in showconfig.aspx I think your file is not getting patched properly.

You can use below steps.

  1. Create a Config file with appropriate name, by using below lines.

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/"> <sitecore> <settings> <setting name="AllowDuplicateItemNamesOnSameLevel"> <patch:attribute name="value">false</patch:attribute> </setting> </settings> </sitecore> </configuration>

  1. Go to App_Config-->Include folder and paste above file there.

  2. Check if the right config value is coming for the settings in showconfig.aspx

  3. Test the issue which you have.

Hope this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.