So according to this article it was a case of jumping into the Core database and setting read and write permissions on the Move To item.


However I am still seeing:

enter image description here

At the Copying level is: enter image description here

For my custom role I have ticked Read and write for both item and descendents.

I have also ticked Read and Write in the child Move To item.

I don't believe that deny setting would affect my custom role as it's not a limited content editor.

enter image description here

Not quite sure why I'm still seeing this permission denied error.

I have confirmed using the access viewer that I think I should have permission to it:

enter image description here

The item I'm trying to move is under workflow - but I have locked it for editing so I should have write permission on that item in order to move it.

I have also tried clicking Create and Delete in the Copying and Move to security rights.

I have also tried updating

/sitecore/content/Applications/WebEdit/Ribbons/WebEdit/Page Editor/Edit/Move Page

to grant this role allow on read, write, create and delete.

But am still getting an error when trying to move something.

  • 1
    Do have "Sitecore client Users" role in your custom role or the member that not have permission? Commented Sep 24, 2019 at 7:14
  • Yes - that is in screenshot above with what the role is a member of.
    – Jen
    Commented Sep 24, 2019 at 22:52

1 Answer 1


Sitecore Support to the rescue:

https://community.sitecore.net/technical_blogs/b/sitecorejohn_blog/posts/who-can-move-items-in-the-sitecore-asp-net-cms "Logically, to move an item, one needs at least read access to the source and destination items. In fact, one needs the delete access right for the source item and the create access right for the destination item."

By adding "Create" and "Delete" access right on the source and target item, the source item can be moved successfully (using the Drag and Drop method).

In order for "Move To" context menu to show up, the user need to have "Read" permission on: /sitecore/content/Applications/Content Editor/Context Menues/Default/Copying

So in order for me to fix I went to our workflow, assigned security details and ticked the Create and Delete for this role. I checked this with access viewer. I also needed to grant permission on the workflow:delete item

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.