3

I was trying to install Sitecore 9.2.0 XP Scaled in Azure using ARM template. But I am getting an error named 'AspNetCoreRuntime' not found.

{
  "id": "/subscriptions/72a1bd21-63be-430d-b8a9-47b3a3e873d8/resourcegroups/mnmsitecorearm1/providers/Microsoft.Web/sites/sitecorexc92-si/siteextensions/AspNetCoreRuntime",
  "name": "sitecorexc92-si/AspNetCoreRuntime",
  "type": "Microsoft.Web/sites/siteextensions",
  "location": "East US",
  "properties": {
    "id": "AspNetCoreRuntime",
    "title": null,
    "type": "Gallery",
    "summary": null,
    "description": null,
    "version": null,
    "extension_url": null,
    "project_url": null,
    "icon_url": null,
    "license_url": null,
    "feed_url": null,
    "authors": null,
    "installer_command_line_params": null,
    "published_date_time": null,
    "download_count": 0,
    "local_is_latest_version": null,
    "local_path": null,
    "installed_date_time": null,
    "provisioningState": "Failed",
    "comment": "'**AspNetCoreRuntime' not found.**"
  }
}

What I have tried:

I have tried with the solution

Adding this piece of code under resource object in template JSON.

{
    "type": "Microsoft.Resources/siteextensions",
    "name": "AspNetCoreRuntime.3.0.x64",
    "apiVersion": "[variables('resourcesApiVersion')]",
    "location": "[resourceGroup().location]",
    "properties": {
        "parameters": {
            "standard": {
                "value": {
                    "deploymentId": "[parameters('deploymentId')]"
                }
            }
        }
    },
    "dependsOn": [
        "[resourceId('Microsoft.Resources/deployments', concat(parameters('deploymentId'), '-infrastructure'))]"
    ]
}

src: Sitecore Identity server deployment: "AspNetCoreRuntime extension not found" | bramstoop.com[^]

But the result is same.

  • 1
    The Sitecore Azure quickstart templates have been updated to remove AspNetRuntime. – gilmae Sep 25 at 23:15
3

The deployment in marketplace is not working right now because of an issue with the AspNetCoreRuntime' extensions.

This issue was already fixed for ARM templates that can be used with Azure Toolkit: https://github.com/Sitecore/Sitecore-Azure-Quickstart-Templates/tree/master/Sitecore%209.1.1

The fix for the Marketplace deployments is currently in progress. Please refer to the below link for more details and the status updates regarding this issue:

http://status.cloud.sitecore.net/maintenance/87d23f4d-9a48-47fe-b483-5c3bd52cb918

UPDATE - THIS ISSUE IS NOW RESOLVED.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.