2

When trying to select a Media item for a field the Date Uploaded filter returns no results. This is in Sitecore 9.1.1. Here are the steps to reproduce:

  1. Navigate to a content item with an Image field
  2. In the Image field click Browse. Select Media dialog box opens
  3. Click the Upload Media button
  4. Upload a file
  5. You should still be in the Select Media dialog box. Click the Filters drop down
  6. You will see that in the Date Uploaded section it should show some number for "Today". Check the checkbox next to "Today"
  7. Sitecore says "No items found"

(See screen shots) enter image description here

enter image description here

  • Looks like your index needs a rebuild. Its probably out of sync and hasn't updated with the images yet. – Richard Seal Sep 30 at 13:43
  • Hmmm. So every time an author adds a new image we need to rebuild the entire Master index? – Corey Burnett Sep 30 at 13:44
  • Also - the other filters do work. The Dimensions and Media Type filters work fine. – Corey Burnett Sep 30 at 13:45
  • Today might mean "Today, in Server Time". What timezone are you in? – Mark Cassidy Sep 30 at 14:44
  • I am running it on my local laptop. So the server is in US Eastern time. – Corey Burnett Sep 30 at 14:46
3

I opened a support ticket with Sitecore and they provided a solution. They referenced Sitecore bug 304447. The solution is to add the following to your Sitecore config via a patch file:

<setting name="ContentSearch.DateFormat" value="yyyy-MM-dd'T'HH:mm:ss'Z'"/>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.