2

I have added some SXA components to the page (say I have added a linklist SXA component to the Home item). I have also added the workflow to different Sitecore items (Home item is assigned a workflow but it is not assigned to the datasource of LinkList SXA component).

The issue that I am facing is even if the Home item is in an approved workflow state, the state of the datasource of component LinkList does not change to the approved state, it is still in draft state which breaks the Home page. I have to manually move the LinkList datasource item to approved state to make the page work.

My questions:

1) When I have not assigned workflow to the datasource items, why are these items going into the workflow state at the first place?

2) Even if the item is going in the workflow state then, when the main item is in approved state, why all the components' datasource added to that item are not in the same state?

This is not just happening with LinkList component but many other SXA provided/customized components.

Am I missing something?

  • for your point 1) can you make sure you don't have any default workflow on the standard value of the item? – Mahendra Shekhawat Oct 2 at 18:00
  • Are you using out of the box workflow or through a custom code? Also ensure that the workflows are assigned only to the Page Standard Values Item and not any other Templates. Navigate to the LinkList Template Standard Values and the check the Default Workflow field. Ideally it should be empty. – Sumit Upadhyay Oct 8 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.