3

I have installed a fresh Sitecore 8.2 and deployed the solution built on 8.1 u2 on top of it.

I have updated all dll references beforehand to point to Sitecore NuGet for 8.2 version and updated web.config in the source control.

The site starts ok but i don't find any analytics data. I can see the visits in Experience Profile, but analytics dashboard is blank.

I am running SOLR as a content search provider.

I can see lots of exceptions like this in the log:

9552 16:45:13 ERROR Aggregation Error
Exception: System.InvalidOperationException
Message: Exception has been thrown by the target of an invocation.
Source: Sitecore.ExperienceAnalytics.Aggregation
   at Sitecore.ExperienceAnalytics.Aggregation.Pipeline.SegmentProcessor.ProcessSegments(AggregationPipelineArgs args, IEnumerable`1 segments)
   at Sitecore.ExperienceAnalytics.Aggregation.Pipeline.SegmentProcessor.OnProcess(AggregationPipelineArgs args)
   at Sitecore.Analytics.Aggregation.Pipeline.AggregationProcessor.Process(AggregationPipelineArgs args)

Nested Exception

Exception: System.Reflection.TargetInvocationException
Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Sitecore.Reflection.ReflectionUtil.CreateObject(Type type, Object[] parameters)
   at Sitecore.Configuration.DefaultFactory.CreateFromTypeName(XmlNode configNode, String[] parameters, Boolean assert)
   at Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert, IFactoryHelper helper)
   at Sitecore.Configuration.DefaultFactory.CreateObject(XmlNode configNode, Boolean assert)
   at Sitecore.Configuration.DefaultFactory.CreateObject[T](XmlNode configNode)
   at Sitecore.ExperienceAnalytics.Aggregation.AggregationContainer.Repositories.<.cctor>b__1()
   at Sitecore.ExperienceAnalytics.Aggregation.Data.Model.AggregationSegment.get_Dimension()
   at Sitecore.ExperienceAnalytics.Aggregation.Data.Model.AggregationSegment.GetData(IVisitAggregationContext context)
   at Sitecore.ExperienceAnalytics.Aggregation.Pipeline.SegmentProcessor.ProcessSegments(AggregationPipelineArgs args, IEnumerable`1 segments)

Nested Exception

Exception: System.TypeLoadException
Message: Could not load type 'Sitecore.ExperienceAnalytics.Aggregation.Dimensions.DimensionBase' from assembly 'Sitecore.ExperienceAnalytics, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null'.
Source: mscorlib
   at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type)
   at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
   at Sitecore.Reflection.ReflectionUtil.CreateObject(String assembly, String className, Object[] parameters)
   at Sitecore.ExperienceAnalytics.Aggregation.Repositories.DimensionConfigReader.CreateDimensionFromConfig(XmlElement childNode)
   at Sitecore.ExperienceAnalytics.Aggregation.Repositories.DimensionConfigReader.LoadDimensionsFromConfig(String pathToConfigNode)

Actually I tried dis-assembling that dll and that type exists.

  • I'm a bit confused: how did you do the upgrade? – Gatogordo Nov 5 '16 at 16:09
  • it was more like migration than upgrade. So installed plain sitecore 8.2, deployed there all templates and items.. and custom codebase. – Volodymyr Hil Nov 5 '16 at 16:22
  • You might need to do the rebuild of the analytics (I though that it was not necessary when just upgrading, but as you did not upgrade but just moved data into an empty 8.2 that might be needed now) - I'm not certain though so verify here of with sc support – Gatogordo Nov 5 '16 at 16:31
  • I have figured out that is related to EXM aggregation. so there is EXM 3.3.0 If i disable these configs: Website\App_Config\Include\EmailExperience\Sitecore.EmailExperience.ExperienceAnalytics.Aggregation.config.disabled Website\App_Config\Include\EmailExperience\Sitecore.EmailExperience.ExperienceAnalytics.Reduce.config.disabled I see no exceptions.. Something is wrong around EXM... – Volodymyr Hil Nov 5 '16 at 18:19
2

EXM 3.3 does not run on Sitecore 8.2, so it makes sense that it's causing aggregation problems.

EXM 3.3 only runs on Sitecore 8.1 update 3 (rev. 160519).

EXM 3.4 runs on Sitecore 8.2 (rev. 160729).

You are always able to see which Sitecore version is required by a specific version of EXM on the Email Experience Manager download page

2

I have figured out that is related to EXM aggregation. so there is EXM 3.3.0 If i disable these configs:

Website\App_Config\Include\EmailExperience\Sitecore.EmailExp‌​erience.ExperienceAn‌​alytics.Aggregation.‌​config

Website\App_Config\Include\EmailExperience\Sitecore.EmailExp‌​erience.ExperienceAn‌​alytics.Reduce.confi‌​g

I see no exceptions.. Something is wrong around EXM... I also tried to install clean sitecore 8.2 and EXM on it - same error so nothing related to my code.

  • 2
    Sitecore 8.2 does not support EXM 3.3. You must wait for EXM 3.4. – Jacob Nielsen Nov 5 '16 at 19:03
  • what EXM does it support then? :) – Volodymyr Hil Nov 5 '16 at 19:08
  • EXM 3.3 targets Sitecore 8.1 update 3, EXM 3.4 targets Sitecore 8.2 – Jacob Nielsen Nov 5 '16 at 19:09
  • EXM 3.4 will be released very soon. Also, the download page (dev.sitecore.net/Downloads/Email_Experience_Manager.aspx) specifically mentions which version of Sitecore is supported for each EXM version – Jacob Nielsen Nov 5 '16 at 19:16
  • 1
    @JacobNielsen You should make an answer out of your comments. This way, other users will have a quick way of seeing the right answer. – Dmytro Shevchenko Nov 6 '16 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.