0

I'm using Sitecore Forms. With a Fresh install of Sitecore 9.2 and I don't see any submit actions. As far as I have read, it should come with 5 different standard presets.

Any idea what I'm missing or what's wrong?

There are no actions to display

EDIT After looking again it looks like i get this Error message in my console.

{"message":"An error has occurred.","exceptionMessage":"The required anti-forgery form field \"__RequestVerificationToken\" is not present.","exceptionType":"System.Web.Mvc.HttpAntiForgeryException","stackTrace":"   at System.Web.Helpers.AntiXsrf.TokenValidator.ValidateTokens(HttpContextBase httpContext, IIdentity identity, AntiForgeryToken sessionToken, AntiForgeryToken fieldToken)\r\n   at System.Web.Helpers.AntiXsrf.AntiForgeryWorker.Validate(HttpContextBase httpContext)\r\n   at Sitecore.Web.Http.Filters.ValidateHttpAntiForgeryTokenAttribute.OnAuthorization(HttpActionContext actionContext)"}
  • 1
    Try clearing your browser cache – Marek Musielak Oct 8 '19 at 13:33
  • @MarekMusielak Thank you. I had to do a total cache clear, and not just on the page. And then it worked. – Tobias Heide Oct 8 '19 at 13:35
  • 1
    I'm glad it helped. I added some more information and converted my comment into an answer. – Marek Musielak Oct 8 '19 at 13:53
5

This data is stored in a browser's cache and if it's there, browser doesn't send requests again to the server to get updated information.

It may happen that before some internal caches are rebuilt, you sent the first request and you receive "There are no actions to display" message.

If that's the case, clearing the browser's cache and maybe restarting the browser after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.