2

I have a Sitecore Adaptive Images module in one of our Sitecore applications. I just finished upgrading it from 7.2 to 8.2. I am now doing some fine-tuning. I see the error below in the log. How can I fix this?

13320 15:15:36 ERROR Error loading hook: 
Exception: System.NotSupportedException
Message: Specified method is not supported.
Source: Sitecore.Kernel
   at Sitecore.Resources.Media.MediaManager.set_Provider(MediaProvider value)
   at SitecoreAdaptiveImages.AdaptiveImagesMediaProviderHook.Initialize() in C:\Projects\OmniHotels\Source\C2\Upgrade-branch\SitecoreAdaptiveImages\AdaptiveImagesMediaProviderHook.cs:line 9
   at Sitecore.Events.Hooks.HookManager.LoadAll()

It is complaining about this line in the code for the hook. How do I fix it?

enter image description here

3

Thanks to a post by @jammykam saved me. Here is the post : https://jammykam.wordpress.com/2015/12/03/sitecore-media-library-in-azure-cloud-storage-part-2/

All I had to do was change the config file. I commented out the hook and add a patch for medialibrary. See the screenshot below.

I thought it would be better to post my finding, as someone else who have the Adaptive Images module installed and upgrading to Sitecore 8.2 could run into same issue and get help from here. :)

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.