-1

Sitecore 9.2.0 installation has been done successfully with no error. Now while installing Sitecore packages for
Sitecore Powershell Extensions 5.0 For Sitecore 9.2 installed successfully but Sitecore Experience Accelerator 1.9.0 for Sitecore 9.2 not getting installed.

Error as
The installation failed.
Incorrect syntax near 'INDEX'. If this is intended as a part of a table 
hint, A WITH keyword and parenthesis are now required. 
See SQL Server Books Online for proper syntax.
For more information see the Sitecore log.
Try one of the following options:
Retry the installation

I tried after rebuilding search indexes, but still, issue.

After looking at logs getting error as

ManagedPoolThread #8 07:16:23 INFO  Installing item:
 items/core/sitecore/client/Applications/ExperienceEditor/Dialogs/MapPointSelectorDialog/PageSettings/OK/{B4C7E721-1990-4F79-AC90-7F2DAA8B0F44}/en/1/xml
ManagedPoolThread #8 07:16:23 ERROR Error installing items/core/sitecore/client/Applications/ExperienceEditor/Pipelines/InitializePageEdit/HideSxaStrip/{7ABEE94C-FC0C-4267-9330-051DFC894EA2}/en/1/xml
Exception: System.Exception
Message: Incorrect syntax near 'INDEX'. If this is intended as a part of a table hint, A WITH keyword and parenthesis are now required. See SQL Server Books Online for proper syntax.

Attaching screenshot while checking same item in core database enter image description here

  • If i am not mistaken, you should install the powershell extension 5.1 for 9.2 – Hishaam Namooya Oct 11 at 12:15
  • thanks @HishaamNamooya but while installing package giving prerequestics info as Sitecore Experience Accelerator installation. Before you install the SXA package, please make sure that you have installed: 1. Sitecore Experience Platform 9.2 Initial Release. 2. Sitecore PowerShell extensions 5.0 for Sitecore 9.2 from https://marketplace.sitecore.net/Modules/S/Sitecore_PowerShell_console.aspx After the package is installed, please rebuild search indexes. – Pradeep Gupta Oct 11 at 12:20
  • 2
    It should be Sitecore Powershell Extension 5.1 or 5.0 if you are downloading from the dev.sitecore.net. Moreover, please check the logs to see if there are any additional errors or information that you can share – Hishaam Namooya Oct 11 at 12:22
  • Sitecore PowerShell Extensions 5.1 works with Sitecore 9.2 As you have already installed 5.0, you would first need to delete the SPE 5.0 dlls and configs before trying again. – Sumit Upadhyay Oct 11 at 19:57
  • @HishaamNamooya thanks for your comment, tried with 5.1 also - no success. updated question with log details and screenshot. – Pradeep Gupta Oct 12 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.