2

I'm trying to move a package of automated email campaigns to another environment.

  • I created a sitecore package from the Email \ Messages bucket folder for two draft automated email campaigns.
  • I then imported in my test environment, and using Content Editor I clicked on the Open EXM button.
  • I made changes and saved the template such that it appeared in my EXM Draft Campaign list.
  • I then set it to be active, and it appears in the EXM Automated Campaign list.

But within my Marketing Automation Journey - Send Email action I cannot see either of my 2 imported email campaigns.

enter image description here

They are both definitely Automated and Active (have deactivated them and re-activated them). I have rebuilt the sxa web index, sxa master index, master index. Still cannot see the campaigns in the drop down list.

Is there another content item I needed to include in the package? Or some way of getting it to appear in the drop down list that I have missed out on?

Using Sitecore 9.1.1 and SXA 1.8.1.

enter image description here

enter image description here

2

Not sure of the underlying reason for it, however if you deactivate the message it will be unprotected and you can then move it to the dynamically created folder in the environment that you've moved it to. If you then activate it, the campaign will appear in the list of available campaigns in your Marketing Automation plan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.