0

This is the command : jss deploy app -c -d, I am deploying the newly created jss site in to Sitecore 9.2

Error: Could not load type Sitecore.Jobs.Job from assembly Sitecore.Kernel

enter image description here

  • Try to install sitecore powershell 5.1 – Hishaam Namooya Oct 17 at 20:09
  • Tried it, no luck – sai Oct 17 at 23:24
2

You need to upgrade JSS to JSS 12.

  • It's already in JSS 12 jss --version 12.0.0 – sai Oct 17 at 19:42
  • Right. But that error, is from a Sitecore 9.1 DLL in a 9.2 solution. If you call up your local Sitecore instance, it's likely you will see the exact same error - JSS deploy or otherwise. – Mark Cassidy Oct 17 at 20:10
  • I was able to load the sitecore 9.2 with no issues. – sai Oct 17 at 23:13
  • @sai please mark this answer as accepted if it solved the issue. – Surya Oct 18 at 9:01
  • 1
    Installing Sitecore JavaScript Services 12.0.0 fixed the issue. dev.sitecore.net/Downloads/Sitecore_JavaScript_Services/120/… – sai Oct 20 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.